Skip to content

← Actionable
Low, CVSS 2.1

Craft CMS Vulnerable to Stored XSS in Settings Names and Field Options

CVE-2026-56393GHSA-4mgv-366x-qxvx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/cms

    Affected
    >= 5.0.0-RC1, < 5.9.0-beta.1>= 4.0.0-RC1, < 4.17.0-beta.1
    Fixed in
    5.9.0-beta.1, 4.17.0-beta.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P · score source
EPSS
  • CVE-2026-56393: 0.22% estimated exploitation activity in the next 30 days; percentile 13.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview of all XSS Reports Multiple stored XSS vulnerabilities were found in Craft CMS. They were split into 4 reports as follows: | Report | What's Vulnerable | Why Separate | |--------|-------------------|--------------| | This Report (1) | Multiple settings names | Twig Template: includes/forms/checkbox.twig | | Report 2 | Entry Types Name | Twig Template: includes/forms/editableTable.twig | | Report 3 | Card Attributes in Field Layout | helpers/Cp.php | | Report 4 (Commerce) | Product Type Name | Source in Commerce, sink in CMS - will report this one via Commerce GHSA | Reports 2, 3, and 4 are clearly distinct locations. For this report (Report 1), it was not clear whether to split or consolidate these 7 bugs. The bug report was consolidated and the final categorization should be left to the judgement of the user. Note: This overview is only in this Report. Other reports only reference this one. --- Summary Stored XSS in multiple settings. Names/labels are rendered without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4mgv-366x-qxvx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56393

Advisory: Craft CMS Vulnerable to Stored XSS in Settings Names and Field Options
IDs: CVE-2026-56393, GHSA-4mgv-366x-qxvx
Record: https://patchnext.com/advisories/cve-2026-56393 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.9.0-beta.1, 4.17.0-beta.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/cms: affected >= 5.0.0-RC1, < 5.9.0-beta.1; >= 4.0.0-RC1, < 4.17.0-beta.1; fixed in 5.9.0-beta.1, 4.17.0-beta.1

## Suggested inspection (read-only)
- Packagist craftcms/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4mgv-366x-qxvx (GitHub-reviewed advisory GHSA-4mgv-366x-qxvx lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 =4.0.0-RC1 <4.17.0-beta.1)

Commands are suggestions: review each one before running it.

Loading voting…