Craft CMS Vulnerable to Stored XSS via User Group Name in User Permissions Page
CVE-2026-56381GHSA-g3hp-vvqf-8vw6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.8.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 5.0.0-RC1, <= 5.8.21
- Fixed in
- 5.8.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3hp-vvqf-8vw6 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <=5.8.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-56381: 0.18% estimated exploitation activity in the next 30 days; percentile 7.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored XSS vulnerability exists in the User Permissions page. The User Group name is rendered without proper HTML escaping in the permissions section, allowing an attacker to execute arbitrary JavaScript when another user views or edits a user's permissions. [!NOTE] This is a separate vulnerability from the previously reported "Stored XSS via User Group Name in User Settings Page" and "Multiple Stored XSS in User Group Edit Page". This affects a different sink: the individual user's permissions page. Proof of Concept Required Permissions - Admin access - allowAdminChanges is enabled in production, which is against our security recommendations. Steps to Reproduce 1. Log in to the control panel as an admin 2. Navigate to Settings → Users → User Groups 3. Create or edit a user group and set the Name field to: 4. Save the user group 5. Navigate to Users and edit any user (/admin/users/{id}) 6. Click on the Permissions tab 7. XSS executes Mitigation Sanitize user group names…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g3hp-vvqf-8vw6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56381 Advisory: Craft CMS Vulnerable to Stored XSS via User Group Name in User Permissions Page IDs: CVE-2026-56381, GHSA-g3hp-vvqf-8vw6 Record: https://patchnext.com/advisories/cve-2026-56381 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.8.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 5.0.0-RC1, <= 5.8.21; fixed in 5.8.22 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g3hp-vvqf-8vw6 (GitHub-reviewed advisory GHSA-g3hp-vvqf-8vw6 lists affected ranges: Packagist craftcms/cms >=5.0.0-RC1 <=5.8.21) Commands are suggestions: review each one before running it.
Loading voting…