Skip to content

← Actionable
Medium, CVSS 6.3amended

n8n: Webhook Forgery on Github Webhook Trigger

CVE-2026-56357GHSA-mqpr-49jj-32rc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.5.0, 1.123.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    < 1.123.15>= 2.0.0, < 2.5.0
    Fixed in
    2.5.0, 1.123.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2026-56357: 0.31% estimated exploitation activity in the next 30 days; percentile 24.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker who knows the webhook URL of a workflow using the GitHub Webhook Trigger node could send unsigned POST requests and trigger the workflow with arbitrary data. The node did not implement the HMAC-SHA256 signature verification that GitHub provides to authenticate webhook deliveries, allowing any party to spoof GitHub webhook events. Patches The issue has been fixed in n8n versions 2.5.0 and 1.123.15. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Restrict network access to the n8n webhook endpoint to known GitHub webhook IP ranges. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mqpr-49jj-32rc

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mqpr-49jj-32rc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56357

Advisory: n8n: Webhook Forgery on Github Webhook Trigger
IDs: CVE-2026-56357, GHSA-mqpr-49jj-32rc
Record: https://patchnext.com/advisories/cve-2026-56357 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.5.0, 1.123.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected < 1.123.15; >= 2.0.0, < 2.5.0; fixed in 2.5.0, 1.123.15

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mqpr-49jj-32rc (OSV record GHSA-mqpr-49jj-32rc lists affected ranges: npm n8n >=0 =2.0.0 <2.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mqpr-49jj-32rc (GitHub-reviewed advisory GHSA-mqpr-49jj-32rc lists affected ranges: npm n8n >=0 =2.0.0 <2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…