Skip to content

← Actionable
Medium, CVSS 5.1amended

n8n: Authenticated XSS and Open Redirect via Form Node

CVE-2026-56354GHSA-w673-8fjw-457c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.12.0, 2.10.4, 1.123.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n

    Affected
    >= 2.11.0, < 2.12.0>= 2.0.0-rc.0, < 2.10.4< 1.123.24
    Fixed in
    1.123.24, 2.10.4, 2.12.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2026-56354: 0.24% estimated exploitation activity in the next 30 days; percentile 14.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An authenticated user with permission to create or modify workflows could configure a Form Node with an unsanitized HTML description field or exploit an overly permissive iframe sandbox policy to perform stored cross-site scripting or redirect end users visiting the form to an arbitrary external URL. The vulnerability could be used to facilitate phishing attacks. Patches The issue has been fixed in n8n versions 1.123.24, 2.10.4 and 2.12.0. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Form node by adding n8n-nodes-base.form to the NODESEXCLUDE environment variable. - Disable the Form Trigger node by adding n8n-nodes-base.formTrigger to the NODESEXCLUDE environment variable. These workarounds do not fully remediate the risk…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w673-8fjw-457c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w673-8fjw-457c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56354

Advisory: n8n: Authenticated XSS and Open Redirect via Form Node
IDs: CVE-2026-56354, GHSA-w673-8fjw-457c
Record: https://patchnext.com/advisories/cve-2026-56354 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n 2.12.0, 2.10.4, 1.123.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n: affected >= 2.11.0, < 2.12.0; >= 2.0.0-rc.0, < 2.10.4; < 1.123.24; fixed in 1.123.24, 2.10.4, 2.12.0

## Suggested inspection (read-only)
- `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w673-8fjw-457c (OSV record GHSA-w673-8fjw-457c lists affected ranges: npm n8n >=2.11.0 =2.0.0-rc.0 =0 <1.123.24 (fixed))
- Verified: https://github.com/advisories/GHSA-w673-8fjw-457c (GitHub-reviewed advisory GHSA-w673-8fjw-457c lists affected ranges: npm n8n >=2.11.0 =2.0.0-rc.0 =0 <1.123.24)

Commands are suggestions: review each one before running it.

Loading voting…