n8n: Legacy ExecuteWorkflow Node Bypassed File Path Restrictions
CVE-2026-56352GHSA-2vx9-7wpg-88jq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.19.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 2.19.3
- Fixed in
- 2.19.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2vx9-7wpg-88jq lists affected ranges: npm n8n >=0 <2.19.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2vx9-7wpg-88jq lists affected ranges: npm n8n >=0 <2.19.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-56352: 0.33% estimated exploitation activity in the next 30 days; percentile 25.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The ExecuteWorkflow node's localFile source option read workflow files from disk without applying checks enforced by other file-reading nodes. An authenticated user with permission to create or modify workflows could supply an arbitrary file path via the REST API, bypassing the N8NRESTRICTFILEACCESSTO restriction. This allowed the attacker to determine whether arbitrary files exist on the server host. Where the targeted path contained a valid workflow JSON file, the file could additionally be loaded and executed, potentially triggering actions on downstream systems connected to that workflow. The localFile source option is hidden from the n8n UI since v1.2 but remains accessible via the REST API. Patches The issue has been fixed in n8n version 2.20.0 or 2.19.3. Users should upgrade to this version or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Restrict workflow…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2vx9-7wpg-88jq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2vx9-7wpg-88jq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56352 Advisory: n8n: Legacy ExecuteWorkflow Node Bypassed File Path Restrictions IDs: CVE-2026-56352, GHSA-2vx9-7wpg-88jq Record: https://patchnext.com/advisories/cve-2026-56352 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.19.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 2.19.3; fixed in 2.19.3 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2vx9-7wpg-88jq (OSV record GHSA-2vx9-7wpg-88jq lists affected ranges: npm n8n >=0 <2.19.3 (fixed)) - Verified: https://github.com/advisories/GHSA-2vx9-7wpg-88jq (GitHub-reviewed advisory GHSA-2vx9-7wpg-88jq lists affected ranges: npm n8n >=0 <2.19.3) Commands are suggestions: review each one before running it.
Loading voting…