vLLM introduced enhanced protection for CVE-2025-62164
CVE-2026-56340GHSA-mcmc-2m55-j8jj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- >= 0.10.2, < 0.13.0
- Fixed in
- 0.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mcmc-2m55-j8jj lists affected ranges: PyPI vllm >=0.10.2 <0.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcmc-2m55-j8jj lists affected ranges: PyPI vllm >=0.10.2 <0.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-56340: 0.64% estimated exploitation activity in the next 30 days; percentile 50.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The fix here for CVE-2025-62164 is not sufficient. The fix only disables prompt embeds by default rather than addressing the root cause, so the DoS vulnerability remains when the feature is enabled. Details vLLM's pending change attempts to fix the root cause, which is the missing sparse tensor validation. PyTorch (~v2.0) disables sparse tensor validation (specifically, sparse tensor invariants checks) by default for performance reasons. vLLM is adding the sparse tensor validation to ensure indices are valid, non-negative, and within bounds. These checks help catch malformed tensors. PoC NA Impact Current fix only added a flag to disable/enable prompt embeds, so by default, prompt embeds feature is disabled in vLLM, which stops DoS attacks through the embeddings. However, It doesn’t address the problem when the flag is enabled and there is still potential for DoS attacks. Changes https://github.com/vllm-project/vllm/pull/30649
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mcmc-2m55-j8jj
- Revision 1 · created ·
Published from osv record GHSA-mcmc-2m55-j8jj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56340 Advisory: vLLM introduced enhanced protection for CVE-2025-62164 IDs: CVE-2026-56340, GHSA-mcmc-2m55-j8jj Record: https://patchnext.com/advisories/cve-2026-56340 (revision 2, source checked 26 Oct 2026, 13:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected >= 0.10.2, < 0.13.0; fixed in 0.13.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mcmc-2m55-j8jj (OSV record GHSA-mcmc-2m55-j8jj lists affected ranges: PyPI vllm >=0.10.2 <0.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mcmc-2m55-j8jj (GitHub-reviewed advisory GHSA-mcmc-2m55-j8jj lists affected ranges: PyPI vllm >=0.10.2 <0.13.0) Commands are suggestions: review each one before running it.
Loading voting…