Cross-site scripting via slot content in Nuxt's head components
CVE-2026-56317GHSA-m3q2-p4fw-w38m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuxt 4.4.7, 3.21.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nuxt
- Affected
- >= 4.0.0, < 4.4.7< 3.21.7
- Fixed in
- 4.4.7, 3.21.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m3q2-p4fw-w38m lists affected ranges: npm nuxt >=4.0.0 =0 <3.21.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m3q2-p4fw-w38m lists affected ranges: npm nuxt >=4.0.0 =0 <3.21.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-56317: 0.34% estimated exploitation activity in the next 30 days; percentile 27.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Nuxt's globally registered <NoScript component (from @unhead/vue head components, re-exported by Nuxt) wrote its default-slot content to the innerHTML of the <noscript head tag, bypassing the HTML escaping that {{ }} interpolation normally applies in Vue templates. Applications that placed untrusted, attacker-controllable data inside a <NoScript slot, for example: would emit that value unescaped inside <noscript in the server-rendered HTML. With scripting enabled, the HTML parser treats <noscript content in <head under the "in head noscript" insertion mode: any tag other than link, meta, noframes, or style implicitly closes <noscript and is re-processed in the head. A payload such as <script...</script therefore escapes the element and executes in the document context. Sibling head components (<Style, <Title) were not affected because they already routed slot text through the safe textContent path. Affected versions All currently supported versions of nuxt that ship the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m3q2-p4fw-w38m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m3q2-p4fw-w38m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56317 Advisory: Cross-site scripting via slot content in Nuxt's head components IDs: CVE-2026-56317, GHSA-m3q2-p4fw-w38m Record: https://patchnext.com/advisories/cve-2026-56317 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nuxt 4.4.7, 3.21.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nuxt: affected >= 4.0.0, < 4.4.7; < 3.21.7; fixed in 4.4.7, 3.21.7 ## Suggested inspection (read-only) - `npm ls nuxt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nuxt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m3q2-p4fw-w38m (OSV record GHSA-m3q2-p4fw-w38m lists affected ranges: npm nuxt >=4.0.0 =0 <3.21.7 (fixed)) - Verified: https://github.com/advisories/GHSA-m3q2-p4fw-w38m (GitHub-reviewed advisory GHSA-m3q2-p4fw-w38m lists affected ranges: npm nuxt >=4.0.0 =0 <3.21.7) Commands are suggestions: review each one before running it.
Loading voting…