Flowise: Unauthenticated Information Disclosure of OAuth Secrets (Cleartext) via GET Request
CVE-2026-56270GHSA-6pcv-j4jx-m4vx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6pcv-j4jx-m4vx lists affected ranges: npm flowise >=0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6pcv-j4jx-m4vx lists affected ranges: npm flowise >=0 <=3.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-56270: 2.05% estimated exploitation activity in the next 30 days; percentile 81.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary I have discovered a critical Missing Authentication vulnerability on the /api/v1/loginmethod endpoint. The API allows unauthenticated users (guests) to retrieve the full SSO configuration of any organization by simply providing an organizationId. The response includes sensitive OAuth credentials (Client Secrets) in cleartext. PoC The following request can be sent by anyone on the internet without any cookies or authorization headers. Request Response: The server returns 200 OK with sensitive credentials: Affected Deployments - FlowiseAI Cloud (cloud.flowiseai.com) - Self-hosted FlowiseAI instances where the /api/v1/loginmethod endpoint is exposed Impact An unauthenticated attacker can harvest sensitive API secrets (Google, Microsoft, GitHub Client Secrets) from any organization on the cloud platform. This leads to complete compromise of the organization's third-party integrations and potential data breaches.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6pcv-j4jx-m4vx
- Revision 1 · created ·
Published from osv record GHSA-6pcv-j4jx-m4vx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56270 Advisory: Flowise: Unauthenticated Information Disclosure of OAuth Secrets (Cleartext) via GET Request IDs: CVE-2026-56270, GHSA-6pcv-j4jx-m4vx Record: https://patchnext.com/advisories/cve-2026-56270 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise: affected <= 3.0.13; fixed in 3.1.0 ## Suggested inspection (read-only) - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6pcv-j4jx-m4vx (OSV record GHSA-6pcv-j4jx-m4vx lists affected ranges: npm flowise >=0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6pcv-j4jx-m4vx (GitHub-reviewed advisory GHSA-6pcv-j4jx-m4vx lists affected ranges: npm flowise >=0 <=3.0.13) Commands are suggestions: review each one before running it.
Loading voting…