Flowise: Weak Default Token Hash Secret
CVE-2026-56269GHSA-m7mq-85xj-9x33
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm flowise
- Affected
- <= 3.0.13
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m7mq-85xj-9x33 lists affected ranges: npm flowise >=0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m7mq-85xj-9x33 lists affected ranges: npm flowise >=0 <=3.0.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.3 · CVSS:4.0/AV:L/AC:H/AT:N/PR:H/UI:A/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2026-56269: 0.13% estimated exploitation activity in the next 30 days; percentile 2.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Detection Method: Kolega.dev Deep Code Scan | Attribute | Value | |---|---| | Location | packages/server/src/enterprise/utils/tempTokenUtils.ts:31-34 | | Practical Exploitability | Medium | | Developer Approver | faizan@kolega.ai | Description The encryption key for token encryption has a weak default value 'Secre$t' when TOKENHASHSECRET environment variable is not set. Affected Code Evidence The default value 'Secre$t' is hardcoded in the source code and is cryptographically weak. This key is used to encrypt user IDs and workspace IDs in JWT tokens. Impact Token forgery - attackers can decrypt and manipulate encrypted token metadata, potentially changing user IDs or workspace IDs to escalate privileges or access unauthorized data. Recommendation Require TOKENHASHSECRET to be set as a strong random value in environment variables. Throw an error on startup if not configured. Use a minimum of 32 bytes of entropy. Notes The TOKENHASHSECRET has a weak hardcoded default 'Secre$t' (lines…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-m7mq-85xj-9x33
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-m7mq-85xj-9x33
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56269 Advisory: Flowise: Weak Default Token Hash Secret IDs: CVE-2026-56269, GHSA-m7mq-85xj-9x33 Record: https://patchnext.com/advisories/cve-2026-56269 (revision 3, source checked 26 Oct 2026, 12:57 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm flowise: affected <= 3.0.13; fixed in 3.1.0 ## Suggested inspection (read-only) - `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flowise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m7mq-85xj-9x33 (OSV record GHSA-m7mq-85xj-9x33 lists affected ranges: npm flowise >=0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m7mq-85xj-9x33 (GitHub-reviewed advisory GHSA-m7mq-85xj-9x33 lists affected ranges: npm flowise >=0 <=3.0.13) Commands are suggestions: review each one before running it.
Loading voting…