Crawl4AI: Multiple Docker API Vulnerabilities - File Write, SSRF, Auth Bypass, XSS, JS Execution
CVE-2026-56266GHSA-365w-hqf6-vxfg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (crawl4ai 0.8.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI crawl4ai
- Affected
- <= 0.8.6
- Fixed in
- 0.8.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-365w-hqf6-vxfg lists affected ranges: PyPI crawl4ai >=0 <=0.8.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/ · score source
- EPSS
- CVE-2026-56266: 0.48% estimated exploitation activity in the next 30 days; percentile 41.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple security vulnerabilities in the Crawl4AI Docker API server affecting endpoints for crawling, markdown/LLM extraction, screenshots, PDFs, webhooks, monitoring, JavaScript execution, and configuration. Vulnerabilities 1. Arbitrary File Write via /screenshot and /pdf (CWE-22, CVSS 9.1) The outputpath parameter accepts arbitrary filesystem paths with no validation. An attacker can overwrite server files (DoS) or write to any appuser-writable location. Fix: Added validateoutputpath() restricting writes to CRAWL4AIOUTPUTDIR (/tmp/crawl4ai-outputs by default). Added Pydantic fieldvalidator rejecting .. traversal sequences. 2. SSRF via Webhook URL (CWE-918, CVSS 8.6) Webhook URLs in /crawl/job and /llm/job accept internal/private IPs with no validation, enabling Server-Side Request Forgery against cloud metadata endpoints (169.254.169.254), internal services, and Docker networks. Fix: Added validatewebhookurl() with blocklist for RFC 1918, loopback, link-local, cloud…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-365w-hqf6-vxfg
- Revision 1 · created ·
Published from ghsa record GHSA-365w-hqf6-vxfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56266 Advisory: Crawl4AI: Multiple Docker API Vulnerabilities - File Write, SSRF, Auth Bypass, XSS, JS Execution IDs: CVE-2026-56266, GHSA-365w-hqf6-vxfg Record: https://patchnext.com/advisories/cve-2026-56266 (revision 2, source checked 26 Oct 2026, 13:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: crawl4ai 0.8.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI crawl4ai: affected <= 0.8.6; fixed in 0.8.7 ## Suggested inspection (read-only) - `python -m pip show crawl4ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on crawl4ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-365w-hqf6-vxfg (GitHub-reviewed advisory GHSA-365w-hqf6-vxfg lists affected ranges: PyPI crawl4ai >=0 <=0.8.6) Commands are suggestions: review each one before running it.
Loading voting…