Skip to content

← Actionable
Critical, CVSS 9.1amended

Chainlit contains a session hijacking vulnerability

CVE-2026-56104GHSA-c39v-8hrw-h448

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainlit 2.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI chainlit

    Affected
    < 2.10.1
    Fixed in
    2.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-56104: 0.42% estimated exploitation activity in the next 30 days; percentile 36.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Chainlit before 2.10.1 contains a session hijacking vulnerability that allows unauthenticated attackers to restore and inherit authenticated user sessions by presenting a valid sessionId during WebSocket session restoration without ownership verification. Attackers can exploit the restoreexistingsession path to assume a victim's permissions and roles, enabling unauthorized invocation of tools and access to data restricted to the authenticated victim.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-c39v-8hrw-h448

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-c39v-8hrw-h448

  4. Revision 1 · created ·

    Published from ghsa record GHSA-c39v-8hrw-h448

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-56104

Advisory: Chainlit contains a session hijacking vulnerability
IDs: CVE-2026-56104, GHSA-c39v-8hrw-h448
Record: https://patchnext.com/advisories/cve-2026-56104 (revision 4, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: chainlit 2.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI chainlit: affected < 2.10.1; fixed in 2.10.1

## Suggested inspection (read-only)
- `python -m pip show chainlit`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on chainlit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c39v-8hrw-h448 (GitHub-reviewed advisory GHSA-c39v-8hrw-h448 lists affected ranges: PyPI chainlit >=0 <2.10.1)
- Verified: https://osv.dev/vulnerability/GHSA-c39v-8hrw-h448 (OSV record GHSA-c39v-8hrw-h448 lists affected ranges: PyPI chainlit >=0 <2.10.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…