Apache Shiro shiro-guice module vulnerable to authentication bypass
CVE-2026-56091GHSA-qj64-jj84-w38j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.shiro:shiro-guice 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.shiro:shiro-guice
- Affected
- >= 2.0.0, < 3.0.0
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qj64-jj84-w38j lists affected ranges: Maven org.apache.shiro:shiro-guice >=2.0.0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qj64-jj84-w38j lists affected ranges: Maven org.apache.shiro:shiro-guice >=2.0.0 <3.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/S:P/AU:Y/V:D/RE:L/U:Amber · score source
- EPSS
- CVE-2026-56091: 0.67% estimated exploitation activity in the next 30 days; percentile 52.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass. This vulnerability is similar to https://www.cve.org/CVERecord?id=CVE-2020-1957, except that it affects the `shiro-guice` module instead of the `shiro-spring` module. This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context. Upgrade to version 3.0.0 or later, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from osv record GHSA-qj64-jj84-w38j
- Revision 1 · created ·
Published from ghsa record GHSA-qj64-jj84-w38j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-56091 Advisory: Apache Shiro shiro-guice module vulnerable to authentication bypass IDs: CVE-2026-56091, GHSA-qj64-jj84-w38j Record: https://patchnext.com/advisories/cve-2026-56091 (revision 2, source checked 4 Nov 2026, 06:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.shiro:shiro-guice 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.shiro:shiro-guice: affected >= 2.0.0, < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - Maven org.apache.shiro:shiro-guice: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.shiro:shiro-guice. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qj64-jj84-w38j (GitHub-reviewed advisory GHSA-qj64-jj84-w38j lists affected ranges: Maven org.apache.shiro:shiro-guice >=2.0.0 <3.0.0) - Verified: https://osv.dev/vulnerability/GHSA-qj64-jj84-w38j (OSV record GHSA-qj64-jj84-w38j lists affected ranges: Maven org.apache.shiro:shiro-guice >=2.0.0 <3.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…