Skip to content

← Actionable
Medium, CVSS 5.5amended

pretix: API leaks check-in data between events of the same organizer

CVE-2026-5600GHSA-wr8q-c73g-m7gp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pretix 2026.3.1, 2026.2.1, 2026.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pretix

    Affected
    >= 2026.3.0, < 2026.3.1>= 2026.2.0, < 2026.2.1>= 2025.10.0, < 2026.1.2
    Fixed in
    2026.2.1, 2026.1.2, 2026.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-5600: 0.26% estimated exploitation activity in the next 30 days; percentile 17.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A new API endpoint introduced in pretix 2025 that is supposed to return all check-in events of a specific event in fact returns all check-in events belonging to the respective organizer. This allows an API consumer to access information for all other events under the same organizer, even those they should not have access to. These records contain information on the time and result of every ticket scan as well as the ID of the matched ticket. Example: { "id": 123, "successful": true, "errorreason": null, "errorexplanation": null, "position": 321, "datetime": "2020-08-23T09:00:00+02:00", "list": 456, "created": "2020-08-23T09:00:00+02:00", "autocheckedin": false, "gate": null, "device": 1, "deviceid": 1, "type": "entry" } An unauthorized user usually has no way to match these IDs (position) back to individual people.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-wr8q-c73g-m7gp

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-wr8q-c73g-m7gp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-5600

Advisory: pretix: API leaks check-in data between events of the same organizer
IDs: CVE-2026-5600, GHSA-wr8q-c73g-m7gp
Record: https://patchnext.com/advisories/cve-2026-5600 (revision 3, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pretix 2026.3.1, 2026.2.1, 2026.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pretix: affected >= 2026.3.0, < 2026.3.1; >= 2026.2.0, < 2026.2.1; >= 2025.10.0, < 2026.1.2; fixed in 2026.2.1, 2026.1.2, 2026.3.1

## Suggested inspection (read-only)
- `python -m pip show pretix`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pretix.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wr8q-c73g-m7gp (OSV record GHSA-wr8q-c73g-m7gp lists affected ranges: PyPI pretix >=2026.3.0 =2026.2.0 =2025.10.0 <2026.1.2 (fixed))
- Verified: https://github.com/advisories/GHSA-wr8q-c73g-m7gp (GitHub-reviewed advisory GHSA-wr8q-c73g-m7gp lists affected ranges: PyPI pretix >=2026.3.0 =2026.2.0 =2025.10.0 <2026.1.2)

Commands are suggestions: review each one before running it.

Loading voting…