Apache Tomcat has a Missing Critical Step in Authentication vulnerability
CVE-2026-55957GHSA-7895-gffq-w6jq
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- >= 11.0.0-M1, < 11.0.5>= 10.1.0-M1, < 10.1.37>= 9.0.0.M1, < 9.0.101>= 8.5.0, <= 8.5.100<= 7.0.109
- Fixed in
- 9.0.101, 10.1.37, 11.0.5
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.5>= 10.1.0-M1, < 10.1.37>= 9.0.0.M1, < 9.0.101>= 8.5.0, <= 8.5.100<= 7.0.109
- Fixed in
- 9.0.101, 10.1.37, 11.0.5
Maven org.apache.tomcat:tomcat
- Affected
- >= 11.0.0-M1, < 11.0.5>= 10.1.0-M1, < 10.1.37>= 9.0.0.M1, < 9.0.101>= 8.5.0, <= 8.5.100<= 7.0.109
- Fixed in
- 9.0.101, 10.1.37, 11.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7895-gffq-w6jq lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =0 <=7.0.109
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7895-gffq-w6jq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55957 Advisory: Apache Tomcat has a Missing Critical Step in Authentication vulnerability IDs: CVE-2026-55957, GHSA-7895-gffq-w6jq Record: https://patchnext.com/advisories/cve-2026-55957 (revision 1, source checked 4 Nov 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.5, 10.1.37, 9.0.101; org.apache.tomcat.embed:tomcat-embed-core 11.0.5, 10.1.37, 9.0.101; org.apache.tomcat:tomcat 11.0.5, 10.1.37, 9.0.101. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.5; >= 10.1.0-M1, < 10.1.37; >= 9.0.0.M1, < 9.0.101; >= 8.5.0, <= 8.5.100; <= 7.0.109; fixed in 9.0.101, 10.1.37, 11.0.5 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.5; >= 10.1.0-M1, < 10.1.37; >= 9.0.0.M1, < 9.0.101; >= 8.5.0, <= 8.5.100; <= 7.0.109; fixed in 9.0.101, 10.1.37, 11.0.5 - Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.5; >= 10.1.0-M1, < 10.1.37; >= 9.0.0.M1, < 9.0.101; >= 8.5.0, <= 8.5.100; <= 7.0.109; fixed in 9.0.101, 10.1.37, 11.0.5 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7895-gffq-w6jq (GitHub-reviewed advisory GHSA-7895-gffq-w6jq lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =0 <=7.0.109) Commands are suggestions: review each one before running it.
Loading voting…