Skip to content

← Actionable
Medium, CVSS 6.5

Apache Tomcat has an Improper Authentication vulnerability

CVE-2026-55955GHSA-c5ph-rghf-fjfj

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat-tribes

    Affected
    >= 11.0.0-M1, < 11.0.23>= 10.1.0-M1, < 10.1.56>= 9.0.13, < 9.0.119>= 8.5.38, <= 8.5.100>= 7.0.100, <= 7.0.109
    Fixed in
    10.1.56, 9.0.119, 11.0.23
  • Maven org.apache.tomcat:tomcat

    Affected
    >= 11.0.0-M1, < 11.0.23>= 10.1.0-M1, < 10.1.56>= 9.0.13, < 9.0.119>= 8.5.38, <= 8.5.100>= 7.0.100, <= 7.0.109
    Fixed in
    10.1.56, 9.0.119, 11.0.23

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-c5ph-rghf-fjfj lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.38 =7.0.100 =11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.38 =7.0.100 <=7.0.109

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.118, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c5ph-rghf-fjfj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55955

Advisory: Apache Tomcat has an Improper Authentication vulnerability
IDs: CVE-2026-55955, GHSA-c5ph-rghf-fjfj
Record: https://patchnext.com/advisories/cve-2026-55955 (revision 1, source checked 4 Nov 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-tribes 11.0.23, 10.1.56, 9.0.119; org.apache.tomcat:tomcat 11.0.23, 10.1.56, 9.0.119. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat-tribes: affected >= 11.0.0-M1, < 11.0.23; >= 10.1.0-M1, < 10.1.56; >= 9.0.13, < 9.0.119; >= 8.5.38, <= 8.5.100; >= 7.0.100, <= 7.0.109; fixed in 10.1.56, 9.0.119, 11.0.23
- Maven org.apache.tomcat:tomcat: affected >= 11.0.0-M1, < 11.0.23; >= 10.1.0-M1, < 10.1.56; >= 9.0.13, < 9.0.119; >= 8.5.38, <= 8.5.100; >= 7.0.100, <= 7.0.109; fixed in 10.1.56, 9.0.119, 11.0.23

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat-tribes: check the installed version with your package manager.
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat-tribes, org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c5ph-rghf-fjfj (GitHub-reviewed advisory GHSA-c5ph-rghf-fjfj lists affected ranges: Maven org.apache.tomcat:tomcat >=11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.38 =7.0.100 =11.0.0-M1 =10.1.0-M1 =9.0.13 =8.5.38 =7.0.100 <=7.0.109)

Commands are suggestions: review each one before running it.

Loading voting…