Skip to content

← Actionable
Medium, CVSS 6.3

Bouncy Castle Crypto Package For Java: Use of a Broken or Risky Cryptographic Algorithm vulnerability in bcpkix modules

CVE-2026-5588GHSA-wg6q-6289-32hp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.bouncycastle:bcpkix-jdk18on 1.84; org.bouncycastle:bcpkix-debug-jdk18on 1.84; org.bouncycastle:bcpkix-debug-jdk15to18 1.84; org.bouncycastle:bcpkix-jdk15on 1.84; org.bouncycastle:bcpkix-jdk15to18 1.84; 2 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-wg6q-6289-32hp lists affected ranges: Maven org.bouncycastle:bcpkix-jdk18on >=1.49 =1.49 =1.49 =1.49 =1.49 =1.49 =1.49 <1.84

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/U:Green · score source
EPSS
  • CVE-2026-5588: 0.78% estimated exploitation activity in the next 30 days; percentile 55.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

: Use of a Broken or Risky Cryptographic Algorithm vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA bcpkix on all (pkix modules). PKIX draft CompositeVerifier accepts empty signature sequence as valid. This issue affects BC-JAVA: from 1.49 before 1.84.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wg6q-6289-32hp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-5588

Advisory: Bouncy Castle Crypto Package For Java: Use of a Broken or Risky Cryptographic Algorithm vulnerability in bcpkix modules
IDs: CVE-2026-5588, GHSA-wg6q-6289-32hp
Record: https://patchnext.com/advisories/cve-2026-5588 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.bouncycastle:bcpkix-jdk18on 1.84; org.bouncycastle:bcpkix-debug-jdk18on 1.84; org.bouncycastle:bcpkix-debug-jdk15to18 1.84; org.bouncycastle:bcpkix-jdk15on 1.84; org.bouncycastle:bcpkix-jdk15to18 1.84; org.bouncycastle:bcpkix-jdk14 1.84; org.bouncycastle:bcpkix-debug-jdk14 1.84. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.bouncycastle:bcpkix-jdk18on: affected >= 1.49, < 1.84; fixed in 1.84
- Maven org.bouncycastle:bcpkix-debug-jdk18on: affected >= 1.49, < 1.84; fixed in 1.84
- Maven org.bouncycastle:bcpkix-debug-jdk15to18: affected >= 1.49, < 1.84; fixed in 1.84
- Maven org.bouncycastle:bcpkix-jdk15on: affected >= 1.49, < 1.84; fixed in 1.84
- Maven org.bouncycastle:bcpkix-jdk15to18: affected >= 1.49, < 1.84; fixed in 1.84
- Maven org.bouncycastle:bcpkix-jdk14: affected >= 1.49, < 1.84; fixed in 1.84
- Maven org.bouncycastle:bcpkix-debug-jdk14: affected >= 1.49, < 1.84; fixed in 1.84

## Suggested inspection (read-only)
- Maven org.bouncycastle:bcpkix-jdk18on: check the installed version with your package manager.
- Maven org.bouncycastle:bcpkix-debug-jdk18on: check the installed version with your package manager.
- Maven org.bouncycastle:bcpkix-debug-jdk15to18: check the installed version with your package manager.
- Maven org.bouncycastle:bcpkix-jdk15on: check the installed version with your package manager.
- Maven org.bouncycastle:bcpkix-jdk15to18: check the installed version with your package manager.
- Maven org.bouncycastle:bcpkix-jdk14: check the installed version with your package manager.
- Maven org.bouncycastle:bcpkix-debug-jdk14: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.bouncycastle:bcpkix-jdk18on, org.bouncycastle:bcpkix-debug-jdk18on, org.bouncycastle:bcpkix-debug-jdk15to18, org.bouncycastle:bcpkix-jdk15on, org.bouncycastle:bcpkix-jdk15to18, org.bouncycastle:bcpkix-jdk14, org.bouncycastle:bcpkix-debug-jdk14.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wg6q-6289-32hp (GitHub-reviewed advisory GHSA-wg6q-6289-32hp lists affected ranges: Maven org.bouncycastle:bcpkix-jdk18on >=1.49 =1.49 =1.49 =1.49 =1.49 =1.49 =1.49 <1.84)

Commands are suggestions: review each one before running it.

Loading voting…