SpiceDB: Checks involving relations with caveats can result in unconditional permission when conditional permission is expected
CVE-2026-55866GHSA-4vrg-r928-h5vv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/authzed/spicedb 1.54.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.34.0, < 1.54.0
- Fixed in
- 1.54.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4vrg-r928-h5vv lists affected ranges: Go github.com/authzed/spicedb >=1.34.0 <1.54.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-55866: 0.34% estimated exploitation activity in the next 30 days; percentile 27.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Under concurrency, CheckPermission and CheckBulkPermissions can return PERMISSIONSHIPHASPERMISSION for a (resource, permission, subject) whose correct answer is PERMISSIONSHIPCONDITIONALPERMISSION. You are impacted if all of the following hold: 1. Your schema has a permission combining relations with an intersection or exclusion, where a subject reaches it through a caveated branch and a non-caveated branch. For example: 2. A subject reaches the permission via the caveated edge: 3. Your workload issues LookupResources with a context request parameter, concurrently with CheckPermission/CheckBulkPermissions for the same subject/resource, and 4. The dispatch result cache is enabled. When all of the above are true, there is an intermittent window in which: CheckPermission(document:firstdoc, haspermission, user:caveatedreader) → HASPERMISSION (incorrect; should be CONDITIONALPERMISSION) CheckPermission(document:firstdoc, haspermission, user:caveatedreader, context =…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4vrg-r928-h5vv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55866 Advisory: SpiceDB: Checks involving relations with caveats can result in unconditional permission when conditional permission is expected IDs: CVE-2026-55866, GHSA-4vrg-r928-h5vv Record: https://patchnext.com/advisories/cve-2026-55866 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/authzed/spicedb 1.54.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/authzed/spicedb: affected >= 1.34.0, < 1.54.0; fixed in 1.54.0 ## Suggested inspection (read-only) - Go github.com/authzed/spicedb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/authzed/spicedb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4vrg-r928-h5vv (GitHub-reviewed advisory GHSA-4vrg-r928-h5vv lists affected ranges: Go github.com/authzed/spicedb >=1.34.0 <1.54.0) Commands are suggestions: review each one before running it.
Loading voting…