Skip to content

← Actionable
High, CVSS 7.7amended

GeoNetwork Web Module: Unauthenticaded Server-Side Request Forgery in SLD Tool

CVE-2026-55864GHSA-5hx7-j24v-rffj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geonetwork-opensource:gn-web-app 4.4.12, 4.2.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2026-55864: 1.45% estimated exploitation activity in the next 30 days; percentile 73.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated server-side request forgery vulnerability lets any anonymous user make the GeoNetwork server issue arbitrary outbound HTTP requests. This gives an external attacker a position inside the server's network, making it possible to make internal requests no matter if the response is XML-type or not. The SLD tooling endpoint POST /api/tools/ogc/sld takes a caller-supplied WMS server URL and performs a server-side HTTP GET to it, with no validation. The fetched body can also be stored and downloaded if the output of the outbound request is in XML format, making the SSRF non-blind. Impact Any unauthenticated user can make the server send arbitrary HTTP requests to internal hosts it would never expose publicly, and read the responses back if the request responses are XML. This enables internal data disclosure, for example, configuration files that return as XML, authorization bypass, and reconnaissance of the internal network all from an anonymous position.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5hx7-j24v-rffj

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5hx7-j24v-rffj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55864

Advisory: GeoNetwork Web Module: Unauthenticaded Server-Side Request Forgery in SLD Tool
IDs: CVE-2026-55864, GHSA-5hx7-j24v-rffj
Record: https://patchnext.com/advisories/cve-2026-55864 (revision 3, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geonetwork-opensource:gn-web-app 4.4.12, 4.2.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geonetwork-opensource:gn-web-app: affected >= 4.4.0, <= 4.4.11; >= 4.0.0, <= 4.2.16; fixed in 4.4.12, 4.2.17

## Suggested inspection (read-only)
- Maven org.geonetwork-opensource:gn-web-app: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geonetwork-opensource:gn-web-app.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5hx7-j24v-rffj (OSV record GHSA-5hx7-j24v-rffj lists affected ranges: Maven org.geonetwork-opensource:gn-web-app >=4.4.0 =4.0.0 <4.2.17 (fixed))
- Verified: https://github.com/advisories/GHSA-5hx7-j24v-rffj (GitHub-reviewed advisory GHSA-5hx7-j24v-rffj lists affected ranges: Maven org.geonetwork-opensource:gn-web-app >=4.4.0 =4.0.0 <=4.2.16)

Commands are suggestions: review each one before running it.

Loading voting…