Skip to content

← Actionable
Medium, CVSS 5.9

MariaDB has Cleartext Transmission of Sensitive Information and Insufficiently Protected Credentials

CVE-2026-55854GHSA-42r5-vhpq-m858

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mariadb 3.5.3, 3.4.6, 3.3.3, 3.2.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mariadb

    Affected
    < 3.2.4>= 3.3.0, < 3.3.3>= 3.4.0, < 3.4.6>= 3.5.0, < 3.5.3
    Fixed in
    3.2.4, 3.5.3, 3.3.3, 3.4.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-55854: 0.42% estimated exploitation activity in the next 30 days; percentile 36.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When PAM (dialog) authentication is used, the connector can be coerced into sending the account password in cleartext over an insecure connection. A hostile or man-in-the-middle server can trigger this with the default configuration, disclosing the user's password. Details The mysqlclearpassword plugin is gated behind a secure connection: the driver refuses to transmit the password in cleartext over plain TCP. The sibling PAM plugin handler (SendPamAuthPacketFactory, server-side plugin name dialog) did not override that gate and inherited the default value false, so it was not subject to the same secure-transport requirement. As a result, a hostile or man-in-the-middle server can issue an Authentication Switch Request for the dialog plugin over plain TCP, and the driver responds with the user's password in cleartext. With the default configuration (sslMode=DISABLE, restrictedAuth=null) this is reachable with no non-default options. Am I affected? You are affected if all of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-42r5-vhpq-m858

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55854

Advisory: MariaDB has Cleartext Transmission of Sensitive Information and Insufficiently Protected Credentials
IDs: CVE-2026-55854, GHSA-42r5-vhpq-m858
Record: https://patchnext.com/advisories/cve-2026-55854 (revision 1, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mariadb 3.5.3, 3.4.6, 3.3.3, 3.2.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mariadb: affected < 3.2.4; >= 3.3.0, < 3.3.3; >= 3.4.0, < 3.4.6; >= 3.5.0, < 3.5.3; fixed in 3.2.4, 3.5.3, 3.3.3, 3.4.6

## Suggested inspection (read-only)
- `npm ls mariadb --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mariadb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-42r5-vhpq-m858 (GitHub-reviewed advisory GHSA-42r5-vhpq-m858 lists affected ranges: npm mariadb >=0 =3.3.0 =3.4.0 =3.5.0 <3.5.3)

Commands are suggestions: review each one before running it.

Loading voting…