Skip to content

← Actionable
High, CVSS 8.7

Netty: [codec-haproxy] Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion

CVE-2026-55851GHSA-q6cq-mhr2-jmr5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-haproxy 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.netty:netty-codec-haproxy

    Affected
    >= 4.2.0.Final, <= 4.2.15.Final>= 4.1.0.Final, <= 4.1.135.Final
    Fixed in
    4.2.16.Final, 4.1.136.Final

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55851: 0.63% estimated exploitation activity in the next 30 days; percentile 50.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The HAProxyMessageDecoder in netty's codec-haproxy module performs protocol version detection by reading the 13th byte of the inbound stream as a signed Java byte and widening it to int without masking. When an attacker sends a PROXY protocol v2 binary prefix (0D 0A 0D 0A 00 0D 0A 51 55 49 54 0A) followed by version byte 0xFF, the sign extension produces -1, which collides with the decoder's "need more data" sentinel value. This collision traps the decoder in a version-detection loop where it perpetually requests more data without consuming any bytes, never instantiates the HeaderExtractor that enforces header size limits, and causes ByteToMessageDecoder to accumulate all subsequent inbound bytes into an unbounded cumulation buffer until the JVM exhausts its direct memory allocation.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q6cq-mhr2-jmr5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55851

Advisory: Netty: [codec-haproxy] Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
IDs: CVE-2026-55851, GHSA-q6cq-mhr2-jmr5
Record: https://patchnext.com/advisories/cve-2026-55851 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-haproxy 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-codec-haproxy: affected >= 4.2.0.Final, <= 4.2.15.Final; >= 4.1.0.Final, <= 4.1.135.Final; fixed in 4.2.16.Final, 4.1.136.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-codec-haproxy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-codec-haproxy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q6cq-mhr2-jmr5 (GitHub-reviewed advisory GHSA-q6cq-mhr2-jmr5 lists affected ranges: Maven io.netty:netty-codec-haproxy >=4.2.0.Final =4.1.0.Final <=4.1.135.Final)

Commands are suggestions: review each one before running it.

Loading voting…