Skip to content

← Actionable
High, CVSS 8.6amended

MapFish Print has XXE that allows reading arbitrary files of certain types

CVE-2026-55848GHSA-5v29-34h8-v68r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.mapfish:print.print-servlet 3.28.30; org.mapfish.print:print-lib 4.0.5, 3.33.16, 3.30.32, 3.28.30; org.mapfish.print:print-servlet 4.0.5, 3.33.16, 3.31.24, 3.30.32), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-55848: 0.53% estimated exploitation activity in the next 30 days; percentile 44.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary XXE on MapFish Print allows reading arbitrary files of certain types. Eg /etc/passwd or k8 secrets and certs. https://github.com/mapfish/mapfish-print/commit/13020c0fbc299e5f604e4e66066311c4bf04d507 Details To trigger the XXE it is required to host a remote script and dtd file. When using the Print feature its possible to send the attacker server url as url of the gml layer. The 404 not found path when using the gml Layer will expand the content of the file as path and throw a default 404 with the full content as path. PoC Host this php file somewhere as xxe.php: and beneath host this "evil.dtd" <!ENTITY % exfil "<!ENTITY &#37; error SYSTEM 'file:///xxe-exfil/%payload;'" %exfil; %error; Now send a single curl request against your mapfish print server and include your hosted poc url as gml layer url with the path attached you would like to exfil. It will exfil /var/run/secrets/kubernetes.io/serviceaccount/token (most likely your local test setup wont have it, then just replace…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-5v29-34h8-v68r

  2. Revision 1 · created ·

    Published from osv record GHSA-5v29-34h8-v68r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55848

Advisory: MapFish Print has XXE that allows reading arbitrary files of certain types
IDs: CVE-2026-55848, GHSA-5v29-34h8-v68r
Record: https://patchnext.com/advisories/cve-2026-55848 (revision 2, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.mapfish:print.print-servlet 3.28.30; org.mapfish.print:print-lib 4.0.5, 3.33.16, 3.30.32, 3.28.30; org.mapfish.print:print-servlet 4.0.5, 3.33.16, 3.31.24, 3.30.32. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.mapfish:print.print-servlet: affected >= 3.0.0, < 3.28.30; fixed in 3.28.30
- Maven org.mapfish.print:print-lib: affected >= 3.0.0, < 3.28.30; >= 3.29.0, < 3.30.32; >= 3.32.0, < 3.33.16; >= 3.34.0, < 4.0.5; fixed in 3.33.16, 3.28.30, 3.30.32, 4.0.5
- Maven org.mapfish.print:print-servlet: affected >= 3.29.0, < 3.30.32; >= 3.31.0, < 3.31.24; >= 3.32.0, < 3.33.16; >= 3.34.0, < 4.0.5; fixed in 3.33.16, 3.31.24, 3.30.32, 4.0.5

## Suggested inspection (read-only)
- Maven org.mapfish:print.print-servlet: check the installed version with your package manager.
- Maven org.mapfish.print:print-lib: check the installed version with your package manager.
- Maven org.mapfish.print:print-servlet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.mapfish:print.print-servlet, org.mapfish.print:print-lib, org.mapfish.print:print-servlet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5v29-34h8-v68r (OSV record GHSA-5v29-34h8-v68r lists affected ranges: Maven org.mapfish.print:print-lib >=3.0.0 =3.29.0 =3.32.0 =3.34.0 =3.0.0 =3.29.0 =3.31.0 =3.32.0 =3.34.0 <4.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-5v29-34h8-v68r (GitHub-reviewed advisory GHSA-5v29-34h8-v68r lists affected ranges: Maven org.mapfish.print:print-lib >=3.0.0 =3.29.0 =3.32.0 =3.34.0 =3.0.0 =3.29.0 =3.31.0 =3.32.0 =3.34.0 <4.0.5)

Commands are suggestions: review each one before running it.

Loading voting…