Allure Report: Stored XSS via unescaped ANSI helper in status message/trace rendering
CVE-2026-55847GHSA-gx93-m64w-5m6h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.qameta.allure:allure-generator 2.39.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.qameta.allure:allure-generator
- Affected
- <= 2.38.1
- Fixed in
- 2.39.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gx93-m64w-5m6h lists affected ranges: Maven io.qameta.allure:allure-generator >=0 <=2.38.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-55847: 0.34% estimated exploitation activity in the next 30 days; percentile 27.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The ansi.js Handlebars helper in allure-generator passes user-controlled statusMessage and statusTrace values from test result files through the ansi-to-html library and wraps the output in Handlebars SafeString without HTML escaping. Since ansi-to-html does not escape HTML entities by default, an attacker who can influence test result content (e.g., via crafted JUnit XML failure messages) can inject arbitrary JavaScript that executes when anyone views the generated Allure report. Details The vulnerability is an incomplete fix — commit 4c64b19 (PR #3271) fixed XSS in linky.js and text-with-links.js by adding escapeExpression(), but the same pattern in ansi.js was not addressed. Vulnerable sink — allure-generator/src/main/javascript/helpers/ansi.js:10-11: The AnsiToHtml constructor at line 4 does not set escapeForHtml: true: The ansi-to-html library (v0.7.2) defaults escapeForHtml to false, meaning HTML entities in the input pass through unchanged. Wrapping the result in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gx93-m64w-5m6h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55847 Advisory: Allure Report: Stored XSS via unescaped ANSI helper in status message/trace rendering IDs: CVE-2026-55847, GHSA-gx93-m64w-5m6h Record: https://patchnext.com/advisories/cve-2026-55847 (revision 1, source checked 26 Oct 2026, 16:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.qameta.allure:allure-generator 2.39.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.qameta.allure:allure-generator: affected <= 2.38.1; fixed in 2.39.0 ## Suggested inspection (read-only) - Maven io.qameta.allure:allure-generator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.qameta.allure:allure-generator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gx93-m64w-5m6h (GitHub-reviewed advisory GHSA-gx93-m64w-5m6h lists affected ranges: Maven io.qameta.allure:allure-generator >=0 <=2.38.1) Commands are suggestions: review each one before running it.
Loading voting…