Pocket-ID has an Open Redirect on the OIDC /authorize page via unvalidated redirect_uri with prompt=none
CVE-2026-55834GHSA-2wvm-8mvp-22qv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pocket-id/pocket-id/backend 2.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/pocket-id/pocket-id/backend
- Affected
- >= 2.6.0, <= 2.8.0
- Fixed in
- 2.9.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2wvm-8mvp-22qv lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=2.6.0 <2.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6305 lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=0
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2wvm-8mvp-22qv lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=2.6.0 <=2.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-55834: 0.37% estimated exploitation activity in the next 30 days; percentile 31.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The OIDC authorization page in the pocket-id frontend redirects the browser to an attacker-controlled URL without consulting the backend redirecturi allow-list when the request uses prompt=none. An attacker who knows a valid clientid can craft an /authorize link that sends a victim (or a victim's browser doing a silent re-auth) to any external https URL, enabling phishing and OAuth response smuggling. The backend allow-list validation that protects the normal authenticated flow is bypassed because this path is handled entirely client-side. Details For an OIDC authorization request with prompt=none, the SvelteKit frontend short-circuits the flow before the backend ever validates the redirecturi against the client's registered callback list. File: frontend/src/routes/authorize/+page.ts (line 14) parses the raw redirecturi query parameter from the incoming URL. File: frontend/src/routes/authorize/+page.svelte - in onMount(), when the request carries prompt=none and the user…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2wvm-8mvp-22qv
- Revision 2 · amended ·
Amended from osv record GO-2026-6305
- Revision 1 · created ·
Published from osv record GHSA-2wvm-8mvp-22qv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55834 Advisory: Pocket-ID has an Open Redirect on the OIDC /authorize page via unvalidated redirect_uri with prompt=none IDs: CVE-2026-55834, GHSA-2wvm-8mvp-22qv Record: https://patchnext.com/advisories/cve-2026-55834 (revision 3, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/pocket-id/pocket-id/backend 2.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/pocket-id/pocket-id/backend: affected >= 2.6.0, <= 2.8.0; fixed in 2.9.0 ## Suggested inspection (read-only) - Go github.com/pocket-id/pocket-id/backend: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/pocket-id/pocket-id/backend. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2wvm-8mvp-22qv (OSV record GHSA-2wvm-8mvp-22qv lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=2.6.0 <2.9.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6305 (OSV record GO-2026-6305 lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=0) - Verified: https://github.com/advisories/GHSA-2wvm-8mvp-22qv (GitHub-reviewed advisory GHSA-2wvm-8mvp-22qv lists affected ranges: Go github.com/pocket-id/pocket-id/backend >=2.6.0 <=2.8.0) Commands are suggestions: review each one before running it.
Loading voting…