Skip to content

← Actionable
High, CVSS 7.5

Netty SPDY zlib header block continues decoded expansion after maxHeaderSize truncation

CVE-2026-55833GHSA-mvh2-crg5-v77c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-codec-http 4.2.16.Final, 4.1.136.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven io.netty:netty-codec-http

    Affected
    >= 4.2.0.Final, <= 4.2.15.Final>= 4.1.0.Final, <= 4.1.135.Final
    Fixed in
    4.2.16.Final, 4.1.136.Final

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-55833: 0.66% estimated exploitation activity in the next 30 days; percentile 51.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Netty SPDY header decoding continues inflating zlib-compressed header blocks after the raw header parser has already exceeded maxHeaderSize and marked the frame truncated. At commit b2d2137c4404af425bf9d5d601a62576f5c06925, a 12,253-byte compressed SPDY header block can declare and inflate a 12 MiB header-name field with maxHeaderSize=16, forcing compression-amplified decode and skip work in a reachable SpdyFrameCodec pipeline. PoC poc.zip run with: expected output: The fingerprint means the compressed input was fully consumed while the raw header parser ended with truncated=true and invalid=false after processing the oversized decoded name. That specific state distinguishes this bug from a generic setup failure: the maxHeaderSize guard fired, but the zlib/raw decode path still inflated and skipped the full 12 MiB declared name. Impact A remote unauthenticated peer that can speak SPDY to a Netty pipeline containing SpdyFrameCodec can send a small compressed HEADERS block that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mvh2-crg5-v77c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55833

Advisory: Netty SPDY zlib header block continues decoded expansion after maxHeaderSize truncation
IDs: CVE-2026-55833, GHSA-mvh2-crg5-v77c
Record: https://patchnext.com/advisories/cve-2026-55833 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-codec-http 4.2.16.Final, 4.1.136.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.netty:netty-codec-http: affected >= 4.2.0.Final, <= 4.2.15.Final; >= 4.1.0.Final, <= 4.1.135.Final; fixed in 4.2.16.Final, 4.1.136.Final

## Suggested inspection (read-only)
- Maven io.netty:netty-codec-http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.netty:netty-codec-http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mvh2-crg5-v77c (GitHub-reviewed advisory GHSA-mvh2-crg5-v77c lists affected ranges: Maven io.netty:netty-codec-http >=4.2.0.Final =4.1.0.Final <=4.1.135.Final)

Commands are suggestions: review each one before running it.

Loading voting…