Skip to content

← Actionable
Low, CVSS 3.1amended

Contao: Possible path traversal in job download URIs

CVE-2026-55825GHSA-grm4-wm43-9jh5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 5.7.7; contao/core-bundle 5.7.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-55825: 0.30% estimated exploitation activity in the next 30 days; percentile 22.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An authenticated backend user who can access one job can request an attachment identifier containing ../ segments and make the job attachment download endpoint read a file from another job directory inside var/job-attachments. The controller authorizes only the jobUuid route parameter. The later attachment lookup joins that authorized job UUID with the attacker-controlled identifier, then passes the combined path to the virtual filesystem. VirtualFilesystem::resolve() canonicalizes the whole path and only rejects paths that escape the filesystem mount, so authorized-job/../victim-job/debuglog.csv becomes victim-job/debuglog.csv. This is a cross-job authorization bypass for known job attachment paths. It is not a practical brute-force against unknown jobs because job directories are UUID v4 values. Root Cause JobsController::downloadJobAttachment() checks access to the route jobUuid before loading the attachment: Jobs::getAttachment() then resolves a path built from the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-grm4-wm43-9jh5

  2. Revision 1 · created ·

    Published from osv record GHSA-grm4-wm43-9jh5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55825

Advisory: Contao: Possible path traversal in job download URIs
IDs: CVE-2026-55825, GHSA-grm4-wm43-9jh5
Record: https://patchnext.com/advisories/cve-2026-55825 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/contao 5.7.7; contao/core-bundle 5.7.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/contao: affected >= 5.7.0, < 5.7.7; fixed in 5.7.7
- Packagist contao/core-bundle: affected >= 5.7.0, < 5.7.7; fixed in 5.7.7

## Suggested inspection (read-only)
- Packagist contao/contao: check the installed version with your package manager.
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/contao, contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-grm4-wm43-9jh5 (OSV record GHSA-grm4-wm43-9jh5 lists affected ranges: Packagist contao/contao >=5.7.0 =5.7.0 <5.7.7 (fixed))
- Verified: https://github.com/advisories/GHSA-grm4-wm43-9jh5 (GitHub-reviewed advisory GHSA-grm4-wm43-9jh5 lists affected ranges: Packagist contao/contao >=5.7.0 =5.7.0 <5.7.7)

Commands are suggestions: review each one before running it.

Loading voting…