Contao crawler leaks auth credentials to external hosts
CVE-2026-55824GHSA-3mr9-p497-58f6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 5.7.7, 5.3.47; contao/core-bundle 5.7.7, 5.3.47), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/contao
- Affected
- >= 4.13.0, < 5.3.47>= 5.4.0, < 5.7.7
- Fixed in
- 5.3.47, 5.7.7
Packagist contao/core-bundle
- Affected
- >= 4.13.0, < 5.3.47>= 5.4.0, < 5.7.7
- Fixed in
- 5.3.47, 5.7.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3mr9-p497-58f6 lists affected ranges: Packagist contao/contao >=4.13.0 =5.4.0 =4.13.0 =5.4.0 <5.7.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3mr9-p497-58f6 lists affected ranges: Packagist contao/contao >=4.13.0 =5.4.0 =4.13.0 =5.4.0 <5.7.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.6 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
- EPSS
- CVE-2026-55824: 0.24% estimated exploitation activity in the next 30 days; percentile 15.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Contao's crawler tries to prevent confidential HTTP client options from being sent to external domains by creating a scoped client: full options for root page origins, cleaned options for everything else. The cleaner removes Cookie and Authorization headers, but it removes the non-Symfony option names basicauth and bearerauth instead of Symfony HttpClient's real authbasic and authbearer options. When contao.crawl.defaulthttpclientoptions contains Basic or Bearer authentication for a protected staging/production site, those credentials remain in the "clean" client used for external links or configured additional URIs. An attacker who can get an external URL crawled, for example through a link on a crawled page while the broken-link checker is enabled, can receive the crawler credentials. Technical Detail Root Cause Symfony HttpClient authentication options are authbasic and authbearer; Contao's own manual documents authbasic for crawler Basic Authentication. Because the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3mr9-p497-58f6
- Revision 1 · created ·
Published from osv record GHSA-3mr9-p497-58f6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55824 Advisory: Contao crawler leaks auth credentials to external hosts IDs: CVE-2026-55824, GHSA-3mr9-p497-58f6 Record: https://patchnext.com/advisories/cve-2026-55824 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/contao 5.7.7, 5.3.47; contao/core-bundle 5.7.7, 5.3.47. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/contao: affected >= 4.13.0, < 5.3.47; >= 5.4.0, < 5.7.7; fixed in 5.3.47, 5.7.7 - Packagist contao/core-bundle: affected >= 4.13.0, < 5.3.47; >= 5.4.0, < 5.7.7; fixed in 5.3.47, 5.7.7 ## Suggested inspection (read-only) - Packagist contao/contao: check the installed version with your package manager. - Packagist contao/core-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/contao, contao/core-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3mr9-p497-58f6 (OSV record GHSA-3mr9-p497-58f6 lists affected ranges: Packagist contao/contao >=4.13.0 =5.4.0 =4.13.0 =5.4.0 <5.7.7 (fixed)) - Verified: https://github.com/advisories/GHSA-3mr9-p497-58f6 (GitHub-reviewed advisory GHSA-3mr9-p497-58f6 lists affected ranges: Packagist contao/contao >=4.13.0 =5.4.0 =4.13.0 =5.4.0 <5.7.7) Commands are suggestions: review each one before running it.
Loading voting…