Pillow: WindowsViewer.get_command() OS command injection via unescaped shell path
CVE-2026-55798GHSA-4x4j-2g7c-83w6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pillow 12.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pillow
- Affected
- < 12.3.0
- Fixed in
- 12.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4x4j-2g7c-83w6 lists affected ranges: PyPI pillow >=0 <12.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4x4j-2g7c-83w6 lists affected ranges: PyPI pillow >=0 <12.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- EPSS
- CVE-2026-55798: 0.18% estimated exploitation activity in the next 30 days; percentile 7.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
1. Summary WindowsViewer.getcommand() constructs a cmd.exe shell command by directly embedding a file path into an f-string without escaping. The result is passed to subprocess.Popen(..., shell=True). Shell metacharacters in the file path — most importantly a double-quote (") that breaks out of the wrapping, followed by & — allow injection of arbitrary cmd.exe commands. The macOS equivalent (MacViewer) correctly applies shlex.quote() to the same parameter. The Linux equivalent (UnixViewer) does likewise. Windows is the only platform missing this protection, despite shlex.quote being already imported on line 21 of ImageShow.py. --- 2. Vulnerable Code File: src/PIL/ImageShow.py, lines 133–150 Contrast with macOS — SAFE (line 164–168): Cross-platform summary: | Platform | Class | shlex.quote()? | shell=True? | Safe? | |----------|----------------|------------------|---------------|-------| | macOS | MacViewer | Yes (line 168) | No (list args) | ✅ Yes | | Linux | UnixViewer | Yes (line…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4x4j-2g7c-83w6
- Revision 1 · created ·
Published from osv record GHSA-4x4j-2g7c-83w6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55798 Advisory: Pillow: WindowsViewer.get_command() OS command injection via unescaped shell path IDs: CVE-2026-55798, GHSA-4x4j-2g7c-83w6 Record: https://patchnext.com/advisories/cve-2026-55798 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pillow 12.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pillow: affected < 12.3.0; fixed in 12.3.0 ## Suggested inspection (read-only) - `python -m pip show pillow`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pillow. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4x4j-2g7c-83w6 (OSV record GHSA-4x4j-2g7c-83w6 lists affected ranges: PyPI pillow >=0 <12.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4x4j-2g7c-83w6 (GitHub-reviewed advisory GHSA-4x4j-2g7c-83w6 lists affected ranges: PyPI pillow >=0 <12.3.0) Commands are suggestions: review each one before running it.
Loading voting…