Skip to content

← Actionable
Medium, CVSS 6.9

Craft Commerce: Coupon Code Brute-Force via Rate Limit Bypass

CVE-2026-55795GHSA-h5gm-x9wr-vhcm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/commerce 5.6.5, 4.11.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist craftcms/commerce

    Affected
    >= 5.0.0, <= 5.6.4>= 4.0.0, <= 4.11.1
    Fixed in
    4.11.2, 5.6.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55795: 0.51% estimated exploitation activity in the next 30 days; percentile 43.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The CartController defines a RateLimiter behavior that is only activated when the 'number' POST/GET parameter is explicitly provided. Details When an attacker submits coupon codes against the session-based cart (without passing a 'number' parameter), no rate limiting is applied. This allows unlimited attempts to guess coupon codes. Vulnerable Code <img width="864" height="90" alt="resim" src="https://github.com/user-attachments/assets/a5197f10-f1fd-4331-93f9-9479d0ceebba" / <img width="881" height="272" alt="resim" src="https://github.com/user-attachments/assets/d9db963f-5d1f-4b00-a4b4-5f2dfe2b71dd" / <img width="861" height="271" alt="resim" src="https://github.com/user-attachments/assets/f7842493-3bc0-4e99-956c-7266bab15703" / PoC Complete instructions, including specific configuration details, to reproduce the vulnerability. <img width="909" height="171" alt="resim" src="https://github.com/user-attachments/assets/cfc8c994-5e0c-48de-b728-464029beba0e" / Impact An attacker…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h5gm-x9wr-vhcm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55795

Advisory: Craft Commerce: Coupon Code Brute-Force via Rate Limit Bypass
IDs: CVE-2026-55795, GHSA-h5gm-x9wr-vhcm
Record: https://patchnext.com/advisories/cve-2026-55795 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: craftcms/commerce 5.6.5, 4.11.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist craftcms/commerce: affected >= 5.0.0, <= 5.6.4; >= 4.0.0, <= 4.11.1; fixed in 4.11.2, 5.6.5

## Suggested inspection (read-only)
- Packagist craftcms/commerce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on craftcms/commerce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h5gm-x9wr-vhcm (GitHub-reviewed advisory GHSA-h5gm-x9wr-vhcm lists affected ranges: Packagist craftcms/commerce >=5.0.0 =4.0.0 <=4.11.1)

Commands are suggestions: review each one before running it.

Loading voting…