Craft CMS: Sensitive File Disclosure / Server-Side File Read
CVE-2026-55792GHSA-287w-mxq6-x2cp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (craftcms/cms 5.10.0, 4.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist craftcms/cms
- Affected
- >= 4.0.0-RC1, < 4.18.0>= 5.0.0-RC1, < 5.10.0
- Fixed in
- 5.10.0, 4.18.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-287w-mxq6-x2cp lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <5.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-55792: 0.33% estimated exploitation activity in the next 30 days; percentile 26.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The dataUrl() Twig function is included in Craft’s Twig sandbox allowlist, allowing any control panel user granted the utility:system-messages permission to embed a file-reading payload into system email templates. When those emails are sent, the server reads the target file and returns its contents as a base64-encoded data URL embedded in the email body. The .env file, which typically contains the database password, CRAFTSECURITYKEY, and third-party API keys, passes all of Craft’s existing dataUrl() protection checks and is fully exfiltrated. Obtaining CRAFTSECURITYKEY enables an attacker to forge session tokens and escalate to full admin account takeover. Details Affected versions: Craft CMS 4.x, 5.x (confirmed against 5.9.19) The vulnerability arises from the combination of three code facts: 1. dataUrl is in the Twig sandbox allowlist src/config/twig-sandbox.php, line 115: php'allowedFunctions' = [ ... 'dataUrl', // ← allows file reading inside sandboxed templates ... ], 2.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-287w-mxq6-x2cp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55792 Advisory: Craft CMS: Sensitive File Disclosure / Server-Side File Read IDs: CVE-2026-55792, GHSA-287w-mxq6-x2cp Record: https://patchnext.com/advisories/cve-2026-55792 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: craftcms/cms 5.10.0, 4.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist craftcms/cms: affected >= 4.0.0-RC1, < 4.18.0; >= 5.0.0-RC1, < 5.10.0; fixed in 5.10.0, 4.18.0 ## Suggested inspection (read-only) - Packagist craftcms/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on craftcms/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-287w-mxq6-x2cp (GitHub-reviewed advisory GHSA-287w-mxq6-x2cp lists affected ranges: Packagist craftcms/cms >=4.0.0-RC1 =5.0.0-RC1 <5.10.0) Commands are suggestions: review each one before running it.
Loading voting…