Skip to content

← Actionable
High, CVSS 7.1amended

flyto-core has SSRF guard bypass via IPv6 transition addresses (IPv4-mapped / 6to4 / NAT64) in validate_url_ssrf

CVE-2026-55787GHSA-794r-5rp2-fpg8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flyto-core 2.26.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS
  • CVE-2026-55787: 0.29% estimated exploitation activity in the next 30 days; percentile 21.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary flyto-core's SSRF protection (validateurlssrf / isprivateip in src/core/utils.py) blocks private and metadata destinations by resolving the host and testing the resulting IP for membership in a hardcoded PRIVATEIPRANGES list. That list contains only the native RFC 1918 / loopback / link-local / unique-local ranges. It does not account for IPv6 transition address forms that embed an IPv4 (or loopback) target: - IPv4-mapped ::ffff:a.b.c.d - IPv4-compatible ::a.b.c.d - 6to4 2002::/16 - NAT64 well-known prefix 64:ff9b::/96 and local-use 64:ff9b:1::/48 A workflow author can submit a URL with a literal transition-form host (for example http://[::ffff:127.0.0.1]:8080/... or http://[64:ff9b::a9fe:a9fe]/latest/meta-data/). isprivateip() returns False for these (the address is not literally inside any listed range), so validateurlssrf lets the request through, and the http.get atomic module (and ~10 sibling modules that share the same guard) performs the outbound aiohttp fetch and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-794r-5rp2-fpg8

  2. Revision 1 · created ·

    Published from osv record GHSA-794r-5rp2-fpg8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55787

Advisory: flyto-core has SSRF guard bypass via IPv6 transition addresses (IPv4-mapped / 6to4 / NAT64) in validate_url_ssrf
IDs: CVE-2026-55787, GHSA-794r-5rp2-fpg8
Record: https://patchnext.com/advisories/cve-2026-55787 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flyto-core 2.26.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flyto-core: affected <= 2.26.2; fixed in 2.26.3

## Suggested inspection (read-only)
- `python -m pip show flyto-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flyto-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-794r-5rp2-fpg8 (OSV record GHSA-794r-5rp2-fpg8 lists affected ranges: PyPI flyto-core >=0 <2.26.3 (fixed))
- Verified: https://github.com/advisories/GHSA-794r-5rp2-fpg8 (GitHub-reviewed advisory GHSA-794r-5rp2-fpg8 lists affected ranges: PyPI flyto-core >=0 <=2.26.2)

Commands are suggestions: review each one before running it.

Loading voting…