Skip to content

← Actionable
High, CVSS 8.4amended

flyto-core has Unauthenticated Command Execution via HTTP MCP execute_module

CVE-2026-55786GHSA-h9f9-h6gm-wc85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flyto-core 2.26.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI flyto-core

    Affected
    >= 2.26.2, < 2.26.4
    Fixed in
    2.26.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55786: 0.41% estimated exploitation activity in the next 30 days; percentile 35.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unauthenticated Command Execution via HTTP MCP executemodule Summary The HTTP MCP endpoint (POST /mcp) in flyto-core accepts unauthenticated JSON-RPC tools/call requests and dispatches them to arbitrary registered modules, including sandbox.executeshell, which passes attacker-controlled input directly to asyncio.createsubprocessshell. An unauthenticated attacker can execute arbitrary OS commands as the flyto-core server process. By default the server binds to 127.0.0.1, making this a High-severity local vulnerability (CVSS 8.4); if started with --host 0.0.0.0, it becomes remotely exploitable over the network. Dynamic reproduction confirmed command execution as root inside a Docker container without any Authorization header. Details flyto-core exposes an HTTP API via FastAPI. When the API is started (flyto serve), the MCP router is unconditionally mounted at /mcp (src/core/api/server.py:75-78). The route handler at src/core/api/routes/mcp.py:65-66 declares @router.post("") with no…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h9f9-h6gm-wc85

  2. Revision 1 · created ·

    Published from osv record GHSA-h9f9-h6gm-wc85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55786

Advisory: flyto-core has Unauthenticated Command Execution via HTTP MCP `execute_module`
IDs: CVE-2026-55786, GHSA-h9f9-h6gm-wc85
Record: https://patchnext.com/advisories/cve-2026-55786 (revision 2, source checked 26 Oct 2026, 13:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flyto-core 2.26.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flyto-core: affected >= 2.26.2, < 2.26.4; fixed in 2.26.4

## Suggested inspection (read-only)
- `python -m pip show flyto-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flyto-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h9f9-h6gm-wc85 (OSV record GHSA-h9f9-h6gm-wc85 lists affected ranges: PyPI flyto-core >=2.26.2 <2.26.4 (fixed))
- Verified: https://github.com/advisories/GHSA-h9f9-h6gm-wc85 (GitHub-reviewed advisory GHSA-h9f9-h6gm-wc85 lists affected ranges: PyPI flyto-core >=2.26.2 <2.26.4)

Commands are suggestions: review each one before running it.

Loading voting…