parse-server: Stored XSS via non-standard file extension bypassing file upload extension blocklist
CVE-2026-55778GHSA-v8x7-r927-cc93
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (parse-server 9.9.1-alpha.11, 8.6.81), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm parse-server
- Affected
- >= 9.0.0, < 9.9.1-alpha.11<= 8.6.80
- Fixed in
- 9.9.1-alpha.11, 8.6.81
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v8x7-r927-cc93 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.81 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v8x7-r927-cc93 lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.80
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-55778: 0.55% estimated exploitation activity in the next 30 days; percentile 46.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Parse Server's default fileUpload.fileExtensions blocklist is intended to prevent uploading files that browsers render as active content (such as HTML and SVG), which can be used to perform stored cross-site scripting (XSS) attacks against other users. The blocklist could be bypassed by uploading a file whose extension is not an exact match of a blocked extension (for example a non-standard or compound extension) together with a dangerous content type. On storage adapters that persist and serve the uploaded content type (such as S3 and GCS), the file is then served with the attacker-supplied content type, enabling stored XSS against users who open the file URL. This affects the default configuration, in which authenticated users are allowed to upload files. The default GridFS/filesystem adapter sets the X-Content-Type-Options: nosniff response header, which mitigates browser rendering on that adapter, but the upload restriction itself is still bypassed. This is an…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v8x7-r927-cc93
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v8x7-r927-cc93
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55778 Advisory: parse-server: Stored XSS via non-standard file extension bypassing file upload extension blocklist IDs: CVE-2026-55778, GHSA-v8x7-r927-cc93 Record: https://patchnext.com/advisories/cve-2026-55778 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: parse-server 9.9.1-alpha.11, 8.6.81. A vendor fix does not mean a deployment is fixed. ## Affected components - npm parse-server: affected >= 9.0.0, < 9.9.1-alpha.11; <= 8.6.80; fixed in 9.9.1-alpha.11, 8.6.81 ## Suggested inspection (read-only) - `npm ls parse-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on parse-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v8x7-r927-cc93 (OSV record GHSA-v8x7-r927-cc93 lists affected ranges: npm parse-server >=9.0.0 =0 <8.6.81 (fixed)) - Verified: https://github.com/advisories/GHSA-v8x7-r927-cc93 (GitHub-reviewed advisory GHSA-v8x7-r927-cc93 lists affected ranges: npm parse-server >=9.0.0 =0 <=8.6.80) Commands are suggestions: review each one before running it.
Loading voting…