Skip to content

← Actionable
High, CVSS 8.8

CedarJava has policy injection vulnerability

CVE-2026-55773GHSA-qmch-v2q9-wg4p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.cedarpolicy:cedar-java 4.9.0, 3.4.1, 2.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55773: 0.52% estimated exploitation activity in the next 30 days; percentile 44.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, improper input handling could allow policy injection. Impact Cedar-expression injection via unescaped toCedarExpr() The toCedarExpr() method on Cedar Value types does not escape special characters (" or \) when converting values to Cedar source code. If an integrator uses toCedarExpr() to build policy text at runtime from user-controlled values, an actor could inject arbitrary Cedar expressions. For example, injecting || true into a permit ... when { ... } clause could make the permit unconditional, or injecting && false into a forbid clause could prevent the forbid from triggering. This issue requires the integrator to use toCedarExpr() to build policy text at runtime from user-controlled input. Impacted versions: < 4.9 Patches Addressed in CedarJava version 2.3.6, 3.4.1, and 4.9 and above. We recommend upgrading to the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qmch-v2q9-wg4p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55773

Advisory: CedarJava has policy injection vulnerability
IDs: CVE-2026-55773, GHSA-qmch-v2q9-wg4p
Record: https://patchnext.com/advisories/cve-2026-55773 (revision 1, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.cedarpolicy:cedar-java 4.9.0, 3.4.1, 2.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.cedarpolicy:cedar-java: affected < 2.3.6; >= 3.1.2, < 3.4.1; >= 4.0.0, < 4.9.0; fixed in 4.9.0, 3.4.1, 2.3.6

## Suggested inspection (read-only)
- Maven com.cedarpolicy:cedar-java: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.cedarpolicy:cedar-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qmch-v2q9-wg4p (GitHub-reviewed advisory GHSA-qmch-v2q9-wg4p lists affected ranges: Maven com.cedarpolicy:cedar-java >=0 =3.1.2 =4.0.0 <4.9.0)

Commands are suggestions: review each one before running it.

Loading voting…