Skip to content

← Actionable
High, CVSS 8.8amended

Cedar-Java has policy injection, type confusion, and incorrect equality comparison vulnerabilities

CVE-2026-55771GHSA-4r9r-4425-74p7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.cedarpolicy:cedar-java 4.9.0, 3.4.1, 2.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-55771: 0.57% estimated exploitation activity in the next 30 days; percentile 47.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. Under certain circumstances, it could lead to incorrect equality comparisons. Impact EntityIdentifier.equals() has inverted null/self branches The EntityIdentifier.equals() method has inverted logic for null and self-reference checks, returning true for null comparisons and false for self-comparisons. This does not affect Cedar authorization decisions (computed in Rust from JSON), but could affect integrators who perform their own equality checks on entity identifiers. Impacted versions: < 4.9 Patches It has been addressed in CedarJava version 4.9 and above. We recommend upgrading to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds Avoid relying on EntityIdentifier.equals() for security-sensitive comparisons until upgraded to version 4.9. References If you have any questions or comments…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4r9r-4425-74p7

  2. Revision 1 · created ·

    Published from osv record GHSA-4r9r-4425-74p7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55771

Advisory: Cedar-Java has policy injection, type confusion, and incorrect equality comparison vulnerabilities
IDs: CVE-2026-55771, GHSA-4r9r-4425-74p7
Record: https://patchnext.com/advisories/cve-2026-55771 (revision 2, source checked 26 Oct 2026, 16:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.cedarpolicy:cedar-java 4.9.0, 3.4.1, 2.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.cedarpolicy:cedar-java: affected < 2.3.6; >= 3.1.2, < 3.4.1; >= 4.0.0, < 4.9.0; fixed in 4.9.0, 3.4.1, 2.3.6

## Suggested inspection (read-only)
- Maven com.cedarpolicy:cedar-java: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.cedarpolicy:cedar-java.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4r9r-4425-74p7 (OSV record GHSA-4r9r-4425-74p7 lists affected ranges: Maven com.cedarpolicy:cedar-java >=0 =3.1.2 =4.0.0 <4.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4r9r-4425-74p7 (GitHub-reviewed advisory GHSA-4r9r-4425-74p7 lists affected ranges: Maven com.cedarpolicy:cedar-java >=0 =3.1.2 =4.0.0 <4.9.0)

Commands are suggestions: review each one before running it.

Loading voting…