Skip to content

← Actionable
Medium, CVSS 6.9

opentelemetry-collector-contrib: githubreceiver silently ignores configured required_headers authentication

CVE-2026-55701GHSA-w5cv-pw74-4rxc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver 0.151.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-w5cv-pw74-4rxc lists affected ranges: Go github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver >=0 <=0.150.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55701: 0.70% estimated exploitation activity in the next 30 days; percentile 53.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

githubreceiver Silently Ignores Configured requiredheaders Authentication Summary The githubreceiver webhook handler does not enforce the requiredheaders configuration. Headers are validated at startup (config rejects empty keys/values) but never checked on incoming requests. This follows the same pattern as GHSA-prf6-xjxh-p698 (awsfirehosereceiver auth bypass). Verified against current main. Details In receiver/githubreceiver/config.go, the RequiredHeaders field is defined (line 45) and validated at startup (lines 93-101). But receiver/githubreceiver/tracereceiver.go in handleReq() (lines 131-185) never references RequiredHeaders. The gitlabreceiver enforces the same config correctly at receiver/gitlabreceiver/tracesreceiver.go:266-270: for key, value := range gtr.cfg.WebHook.RequiredHeaders { if r.Header.Get(key) != string(value) { return "", fmt.Errorf("%w: %s", errInvalidHeader, key) } } Amplifying factor The Secret field defaults to empty and has no validation requiring it to be…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w5cv-pw74-4rxc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55701

Advisory: opentelemetry-collector-contrib: githubreceiver silently ignores configured required_headers authentication
IDs: CVE-2026-55701, GHSA-w5cv-pw74-4rxc
Record: https://patchnext.com/advisories/cve-2026-55701 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver 0.151.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver: affected <= 0.150.0; fixed in 0.151.0

## Suggested inspection (read-only)
- Go github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w5cv-pw74-4rxc (GitHub-reviewed advisory GHSA-w5cv-pw74-4rxc lists affected ranges: Go github.com/open-telemetry/opentelemetry-collector-contrib/receiver/githubreceiver >=0 <=0.150.0)

Commands are suggestions: review each one before running it.

Loading voting…