Skip to content

← Actionable
High, CVSS 7.1amended

pnpm: stage download writes outside its destination directory via manifest name/version traversal

CVE-2026-55700GHSA-v23m-ccfg-pq9h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pnpm 11.5.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pnpm

    Affected
    >= 11.3.0, < 11.5.3
    Fixed in
    11.5.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-55700: 0.42% estimated exploitation activity in the next 30 days; percentile 36.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The staged-tarball filename traversal reported as GHSA-v23m-ccfg-pq9h / CAND-PNPM-038 is fixed on main by pnpm/pnpm#12303, merged as 65443f4bdf1f0db9c8c7dc58fee25252607e9234. Before the fix, pnpm stage download derived a local filename from registry-controlled package name and version fields. A crafted manifest could escape the selected download directory and overwrite another reachable file. The merged fix validates both fields, derives one safe filename, and verifies the final destination before writing. Security boundary - Package names and semantic versions are validated before they can influence a local filename. - POSIX and Windows path separators are rejected by basename checks. - Stage download and tarball summary paths use the same filename helper. - The resolved output path must remain an immediate child of the selected download directory. - The stage identifier is already constrained to a UUID. Exploit replay Before 65443f4bdf, a traversal-bearing manifest version…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-v23m-ccfg-pq9h

  2. Revision 1 · created ·

    Published from osv record GHSA-v23m-ccfg-pq9h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55700

Advisory: pnpm: `stage download` writes outside its destination directory via manifest name/version traversal
IDs: CVE-2026-55700, GHSA-v23m-ccfg-pq9h
Record: https://patchnext.com/advisories/cve-2026-55700 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pnpm 11.5.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pnpm: affected >= 11.3.0, < 11.5.3; fixed in 11.5.3

## Suggested inspection (read-only)
- `npm ls pnpm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pnpm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-v23m-ccfg-pq9h (OSV record GHSA-v23m-ccfg-pq9h lists affected ranges: npm pnpm >=11.3.0 <11.5.3 (fixed))
- Verified: https://github.com/advisories/GHSA-v23m-ccfg-pq9h (GitHub-reviewed advisory GHSA-v23m-ccfg-pq9h lists affected ranges: npm pnpm >=11.3.0 <11.5.3)

Commands are suggestions: review each one before running it.

Loading voting…