PowSyBl Core has Command Injection in LocalCommandExecutor-s
CVE-2026-55673GHSA-jqvf-j3ww-r8c7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.powsybl:powsybl-computation-local 7.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.powsybl:powsybl-computation-local
- Affected
- <= 7.2.1
- Fixed in
- 7.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jqvf-j3ww-r8c7 lists affected ranges: Maven com.powsybl:powsybl-computation-local >=0 <7.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jqvf-j3ww-r8c7 lists affected ranges: Maven com.powsybl:powsybl-computation-local >=0 <=7.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-55673: 0.60% estimated exploitation activity in the next 30 days; percentile 48.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Description Both AbstractLocalCommandExecutor OS-dependent implementations are subject to CWE-78 (OS Command Injection), with a secondary CWE-88 (Argument Injection) concern via environment variables. The local command executor build command strings via concatenation and executes them (through bash -c for Unix, or cmd /c for Windows). Any string argument or environment variable value reaching this executor can break out of the intended command and execute arbitrary shell code as the JVM user. The sink is reachable through public APIs that accept List<String arguments without any documented indication that elements undergo shell interpretation. Any caller — CLI, library integration, or embedding service — that forwards data from a less-trusted source into these APIs inherits the vulnerability. Vulnerable elements The vulnerable elements are: - Public methods: - UnixLocalCommandExecutor.execute(...) - WindowsLocalCommandExecutor.execute(...) -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jqvf-j3ww-r8c7
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jqvf-j3ww-r8c7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55673 Advisory: PowSyBl Core has Command Injection in LocalCommandExecutor-s IDs: CVE-2026-55673, GHSA-jqvf-j3ww-r8c7 Record: https://patchnext.com/advisories/cve-2026-55673 (revision 3, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.powsybl:powsybl-computation-local 7.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.powsybl:powsybl-computation-local: affected <= 7.2.1; fixed in 7.2.2 ## Suggested inspection (read-only) - Maven com.powsybl:powsybl-computation-local: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.powsybl:powsybl-computation-local. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jqvf-j3ww-r8c7 (OSV record GHSA-jqvf-j3ww-r8c7 lists affected ranges: Maven com.powsybl:powsybl-computation-local >=0 <7.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-jqvf-j3ww-r8c7 (GitHub-reviewed advisory GHSA-jqvf-j3ww-r8c7 lists affected ranges: Maven com.powsybl:powsybl-computation-local >=0 <=7.2.1) Commands are suggestions: review each one before running it.
Loading voting…