Skip to content

← Actionable
Medium, CVSS 5.6amended

mediasoup: SCTP state cookie lacks cryptographic authentication, enabling unauthorized association establishment (RFC 9260 violation)

CVE-2026-55663GHSA-p7x2-g5cq-fhmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediasoup 0.22.5; mediasoup 3.20.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io mediasoup

    Affected
    >= 0.22.0, <= 0.22.4
    Fixed in
    0.22.5
  • npm mediasoup

    Affected
    >= 3.20.0, <= 3.20.5
    Fixed in
    3.20.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-55663: 0.19% estimated exploitation activity in the next 30 days; percentile 8.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary mediasoup's built-in SCTP stack (introduced in v3.20.0) authenticates SCTP state cookies using only hardcoded magic byte sequences rather than a per-instance HMAC keyed with a secret, violating RFC 9260 Section 5.1.3. An on-path attacker targeting a PlainTransport with SCTP enabled (and no SRTP/DTLS protection) can craft a forged COOKIE-ECHO chunk that passes all validation, establishing an unauthorized SCTP association and gaining the ability to inject DataChannel messages as a trusted peer. Details RFC 9260 Section 5.1.3 states: "An endpoint MUST use a one-time-use secret key to protect the State Cookie." The mediasoup implementation ignores this requirement. The state cookie is defined in worker/include/RTC/SCTP/association/StateCookie.hpp with the following structure (44 bytes total): - Offset 0: Magic1 = "msworker" (hardcoded, 8 bytes) - Offset 8: localVerificationTag (4 bytes, attacker-controlled) - Offset 12: remoteVerificationTag (4 bytes, attacker-controlled) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p7x2-g5cq-fhmq

  2. Revision 1 · created ·

    Published from osv record GHSA-p7x2-g5cq-fhmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55663

Advisory: mediasoup: SCTP state cookie lacks cryptographic authentication, enabling unauthorized association establishment (RFC 9260 violation)
IDs: CVE-2026-55663, GHSA-p7x2-g5cq-fhmq
Record: https://patchnext.com/advisories/cve-2026-55663 (revision 2, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediasoup 0.22.5; mediasoup 3.20.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io mediasoup: affected >= 0.22.0, <= 0.22.4; fixed in 0.22.5
- npm mediasoup: affected >= 3.20.0, <= 3.20.5; fixed in 3.20.6

## Suggested inspection (read-only)
- crates.io mediasoup: check the installed version with your package manager.
- `npm ls mediasoup --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediasoup.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p7x2-g5cq-fhmq (OSV record GHSA-p7x2-g5cq-fhmq lists affected ranges: npm mediasoup >=3.20.0 =0.22.0 <0.22.5 (fixed))
- Verified: https://github.com/advisories/GHSA-p7x2-g5cq-fhmq (GitHub-reviewed advisory GHSA-p7x2-g5cq-fhmq lists affected ranges: npm mediasoup >=3.20.0 =0.22.0 <=0.22.4)

Commands are suggestions: review each one before running it.

Loading voting…