Skip to content

← Actionable
High, CVSS 7.6

Snipe-IT: Tenant Isolation Bypass in FMCS Floater Mode

CVE-2026-55643GHSA-c6w2-j4wq-mvwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snipe/snipe-it 8.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-55643: 0.30% estimated exploitation activity in the next 30 days; percentile 22.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Due to inconsistent authorization checks, a company-scoped user can bypass tenant boundaries to read, mutate, and soft-delete users who do not belong to any company (companyid = null). While direct instance authorization (isCurrentUserHasAccess) correctly denies access to these out-of-scope users, multiple API endpoints and bulk action web routes fail to enforce this restriction, relying instead on class-level permissions or broad scoped queries. Impact: A malicious user scoped to a specific company (e.g., Company A) can: Data Leakage: Extract PII and assigned licenses of users outside their tenant via the API (/api/v1/users and /api/v1/users/{id}/licenses). Data Modification: Mutate out-of-scope user profiles (e.g., changing city, notes) via the /users/bulkeditsave web route. Data Deletion & Asset Theft: Soft-delete out-of-scope users and transfer their assigned assets to themselves via the /users/merge web route. Patches Patched in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c6w2-j4wq-mvwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55643

Advisory: Snipe-IT: Tenant Isolation Bypass in FMCS Floater Mode
IDs: CVE-2026-55643, GHSA-c6w2-j4wq-mvwg
Record: https://patchnext.com/advisories/cve-2026-55643 (revision 1, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snipe/snipe-it 8.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist snipe/snipe-it: affected < 8.6.3; fixed in 8.6.3

## Suggested inspection (read-only)
- Packagist snipe/snipe-it: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snipe/snipe-it.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c6w2-j4wq-mvwg (GitHub-reviewed advisory GHSA-c6w2-j4wq-mvwg lists affected ranges: Packagist snipe/snipe-it >=0 <8.6.3)

Commands are suggestions: review each one before running it.

Loading voting…