9router: Unauthenticated /v1 proxy access via Host-header spoofing → open AI relay + SSRF
CVE-2026-55641GHSA-86m2-fcxq-5q7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- < 0.5.2
- Fixed in
- 0.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-86m2-fcxq-5q7c lists affected ranges: npm 9router >=0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-55641: 0.33% estimated exploitation activity in the next 30 days; percentile 25.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary 9router's request guard decides a request is "local" (and therefore exempt from API-key auth on the /v1 LLM proxy) by reading the client-controlled Host header. Because 9router binds 0.0.0.0 by default (and the CLI misleadingly prints "localhost"), a remote, unauthenticated attacker who can reach the port can send Host: localhost to be treated as local and obtain /v1 proxy access with no API key, no CLI token, and no dashboard login. In the default configuration (requireApiKey is absent from DEFAULTSETTINGS, so the handler-side key check is skipped), this yields: - Open AI relay — the proxy forwards the attacker's requests to AI providers using the victim's stored paid API keys (cost/quota theft, prompt-based data exfiltration through the victim's accounts). - Unauthenticated SSRF — /v1/search with the built-in noAuth searxng provider takes its outbound fetch URL from the request body (provideroptions.baseUrl), so the attacker drives a server-side fetch to any…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-86m2-fcxq-5q7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55641 Advisory: 9router: Unauthenticated `/v1` proxy access via `Host`-header spoofing → open AI relay + SSRF IDs: CVE-2026-55641, GHSA-86m2-fcxq-5q7c Record: https://patchnext.com/advisories/cve-2026-55641 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected < 0.5.2; fixed in 0.5.2 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-86m2-fcxq-5q7c (GitHub-reviewed advisory GHSA-86m2-fcxq-5q7c lists affected ranges: npm 9router >=0 <0.5.2) Commands are suggestions: review each one before running it.
Loading voting…