Skip to content

← Actionable
Critical, CVSS 9.1amended

nextcloud-mcp-server: Unauthenticated POST /webhooks/nextcloud allows arbitrary vector data deletion when WEBHOOK_SECRET is unset ( default )

CVE-2026-55640GHSA-8vh3-g2qg-2h2c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nextcloud-mcp-server 0.117.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-55640: 0.73% estimated exploitation activity in the next 30 days; percentile 54.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The POST /webhooks/nextcloud endpoint has no authentication by default: WEBHOOKSECRET defaults to None and is never required by startup validation. When unset, the receiver accepts any unauthenticated POST. The userid is taken directly from the attacker-supplied payload and passed to Qdrant, allowing an unauthenticated attacker to delete or corrupt vector embeddings for any user. Details Vulnerable file: nextcloudmcpserver/vector/webhookreceiver.py, function handlenextcloudwebhook(), lines 55-67 Root cause 1: Auth check is guarded by if secret: - skipped entirely when WEBHOOKSECRET is unset. Root cause 2: webhooksecret: str | None = None in config - no startup validator enforces it, even when vector sync is enabled. Trusted field: payload["user"]["uid"] in webhookparser.py is used as-is for all Qdrant operations - no cross-check against an authenticated session. webhookreceiver.py, lines 55-67: webhookparser.py, line 57: PoC No credentials required. Works on any deployment…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8vh3-g2qg-2h2c

  2. Revision 2 · amended ·

    Amended from osv record GHSA-8vh3-g2qg-2h2c

  3. Revision 1 · created ·

    Published from ghsa record GHSA-8vh3-g2qg-2h2c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55640

Advisory: nextcloud-mcp-server: Unauthenticated `POST /webhooks/nextcloud` allows arbitrary vector data deletion when `WEBHOOK_SECRET` is unset ( default )
IDs: CVE-2026-55640, GHSA-8vh3-g2qg-2h2c
Record: https://patchnext.com/advisories/cve-2026-55640 (revision 3, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nextcloud-mcp-server 0.117.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nextcloud-mcp-server: affected <= 0.117.1; fixed in 0.117.2

## Suggested inspection (read-only)
- `python -m pip show nextcloud-mcp-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nextcloud-mcp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8vh3-g2qg-2h2c (GitHub-reviewed advisory GHSA-8vh3-g2qg-2h2c lists affected ranges: PyPI nextcloud-mcp-server >=0 <=0.117.1)
- Verified: https://osv.dev/vulnerability/GHSA-8vh3-g2qg-2h2c (OSV record GHSA-8vh3-g2qg-2h2c lists affected ranges: PyPI nextcloud-mcp-server >=0 <0.117.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…