9router: Unauthenticated LLM proxy access via /codex rewrite authorization bypass
CVE-2026-55638GHSA-8gmq-j984-vp4r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- < 0.5.2
- Fixed in
- 0.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8gmq-j984-vp4r lists affected ranges: npm 9router >=0 <0.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
- EPSS
- CVE-2026-55638: 6.58% estimated exploitation activity in the next 30 days; percentile 93.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary 9router exposes an OpenAI/Anthropic-compatible LLM proxy. Remote access to this proxy is intended to be protected by an API-key check in the Next.js middleware. However, 9router also defines a rewrite that maps /codex/ to the backend LLM endpoint /api/v1/responses. The middleware authorization decision is made on the incoming request path before the rewrite is applied. Because /codex is not included in the middleware's protected LLM API prefix list, requests to /codex/ bypass the API-key gate and are later rewritten to the same backend used by /api/v1/responses. As a result, an unauthenticated remote attacker can access the LLM proxy through /codex/ and cause the server to make upstream provider calls using the operator-stored LLM provider credentials. Details | Component | File | Note | | ----------------------------- | ----------------------------------- | ------------------------------------------------------------------------- | | Middleware authorization gate |…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8gmq-j984-vp4r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55638 Advisory: 9router: Unauthenticated LLM proxy access via /codex rewrite authorization bypass IDs: CVE-2026-55638, GHSA-8gmq-j984-vp4r Record: https://patchnext.com/advisories/cve-2026-55638 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected < 0.5.2; fixed in 0.5.2 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8gmq-j984-vp4r (GitHub-reviewed advisory GHSA-8gmq-j984-vp4r lists affected ranges: npm 9router >=0 <0.5.2) Commands are suggestions: review each one before running it.
Loading voting…