Pimcore Vulnerable to Remote Code Execution via DataObject Class-Definition Field Name
CVE-2026-55634GHSA-9x44-4gxf-8c25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 2026.1.6, 12.3.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- <= 12.3.9>= 2026.1.0, <= 2026.1.5
- Fixed in
- 2026.1.6, 12.3.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9x44-4gxf-8c25 lists affected ranges: Packagist pimcore/pimcore >=0 =2026.1.0 <2026.1.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9x44-4gxf-8c25 lists affected ranges: Packagist pimcore/pimcore >=0 =2026.1.0 <=2026.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-55634: 0.65% estimated exploitation activity in the next 30 days; percentile 51.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview A DataObject class-definition field name is concatenated, without an identifier allowlist, into the PHP class source that Pimcore generates for every DataObject class (protected $<fieldName;). A user holding only the ordinary objects (DataObjects) permission can import a class definition whose field name closes the property and injects arbitrary PHP into the generated class file, achieving remote code execution on the server. The same unvalidated field name is also concatenated into ALTER TABLE DDL (ADD COLUMN/ADD INDEX), giving a parallel SQL-injection primitive. This is a sibling of CVE-2026-5394 (composite-index column SQL injection); that fix hardened only the compositeIndices sink and left the field-name path untouched. Impact Any authenticated user with the objects permission — the standard permission for content editors who work with DataObjects, not an administrator or a dedicated "classes" permission — can: 1. Execute arbitrary PHP on the server (RCE). The injected…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9x44-4gxf-8c25
- Revision 1 · created ·
Published from osv record GHSA-9x44-4gxf-8c25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55634 Advisory: Pimcore Vulnerable to Remote Code Execution via DataObject Class-Definition Field Name IDs: CVE-2026-55634, GHSA-9x44-4gxf-8c25 Record: https://patchnext.com/advisories/cve-2026-55634 (revision 2, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 2026.1.6, 12.3.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected <= 12.3.9; >= 2026.1.0, <= 2026.1.5; fixed in 2026.1.6, 12.3.10 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9x44-4gxf-8c25 (OSV record GHSA-9x44-4gxf-8c25 lists affected ranges: Packagist pimcore/pimcore >=0 =2026.1.0 <2026.1.6 (fixed)) - Verified: https://github.com/advisories/GHSA-9x44-4gxf-8c25 (GitHub-reviewed advisory GHSA-9x44-4gxf-8c25 lists affected ranges: Packagist pimcore/pimcore >=0 =2026.1.0 <=2026.1.5) Commands are suggestions: review each one before running it.
Loading voting…