Whistle vulnerable to path traversal
CVE-2026-55629GHSA-3vfr-4gwf-qxfp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (whistle 2.10.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm whistle
- Affected
- < 2.10.3
- Fixed in
- 2.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3vfr-4gwf-qxfp lists affected ranges: npm whistle >=0 <2.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-55629: 0.55% estimated exploitation activity in the next 30 days; percentile 46.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This bug was found by nova, which is an automated tool from group of Song Wu, intern, Zhejiang University; BoWang, independent researcher; Xingwei Lin, Zhejiang University. Vulnerability detail: In service.js, inside app.get('/cgi-bin/temp/get', ...): var filename = req.query.filename; if (TEMPFILERE.test(filename)) { filename = path.join(TEMPFILESPATH, filename); } getFile(filename, ...); Only when filename matches the temp/<hash pattern does it get joined to the safe directory TEMPFILESPATH. If it does not match that pattern, the code does not block the request. Instead, it directly uses the user-supplied filename for file reading. In other words: if you pass passwd, it will read passwd. POC: curl -s "http://127.0.0.1:8899/cgi-bin/temp/get?filename=/etc/passwd" response:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3vfr-4gwf-qxfp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55629 Advisory: Whistle vulnerable to path traversal IDs: CVE-2026-55629, GHSA-3vfr-4gwf-qxfp Record: https://patchnext.com/advisories/cve-2026-55629 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: whistle 2.10.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm whistle: affected < 2.10.3; fixed in 2.10.3 ## Suggested inspection (read-only) - `npm ls whistle --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on whistle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3vfr-4gwf-qxfp (GitHub-reviewed advisory GHSA-3vfr-4gwf-qxfp lists affected ranges: npm whistle >=0 <2.10.3) Commands are suggestions: review each one before running it.
Loading voting…