Skip to content

← Actionable
Medium, CVSS 4.2amended

n8n-MCP: Incorrect authorization can expose default-scope workflow version backups in multi-tenant HTTP mode

CVE-2026-55608GHSA-2cf7-hpwf-47h9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n-mcp 2.57.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm n8n-mcp

    Affected
    <= 2.57.3
    Fixed in
    2.57.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-55608: 0.28% estimated exploitation activity in the next 30 days; percentile 20.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In multi-tenant HTTP mode (ENABLEMULTITENANT=true), an authenticated tenant could, under certain conditions, reach n8n-mcp's local default-scope workflowversions backups instead of being confined to its own tenant scope. This affects n8n-mcp's own local workflow-version storage, not a normal n8n API capability. Impact An authenticated MCP HTTP tenant could read or delete workflow-version backups stored in the default (single-tenant) scope — for example backups left from a prior single-tenant deployment or a migration period. Workflow snapshots may contain sensitive workflow configuration depending on their contents. Single-tenant and stdio deployments are not affected. Affected versions <= 2.57.3 Patched version 2.57.4 Remediation Upgrade to n8n-mcp 2.57.4 or later. The fix requires a complete tenant context in multi-tenant mode and fails closed for workflow-version access that cannot be attributed to a specific tenant. Workarounds - Restrict network access to the HTTP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2cf7-hpwf-47h9

  2. Revision 1 · created ·

    Published from osv record GHSA-2cf7-hpwf-47h9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55608

Advisory: n8n-MCP: Incorrect authorization can expose default-scope workflow version backups in multi-tenant HTTP mode
IDs: CVE-2026-55608, GHSA-2cf7-hpwf-47h9
Record: https://patchnext.com/advisories/cve-2026-55608 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: n8n-mcp 2.57.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm n8n-mcp: affected <= 2.57.3; fixed in 2.57.4

## Suggested inspection (read-only)
- `npm ls n8n-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on n8n-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2cf7-hpwf-47h9 (OSV record GHSA-2cf7-hpwf-47h9 lists affected ranges: npm n8n-mcp >=0 <2.57.4 (fixed))
- Verified: https://github.com/advisories/GHSA-2cf7-hpwf-47h9 (GitHub-reviewed advisory GHSA-2cf7-hpwf-47h9 lists affected ranges: npm n8n-mcp >=0 <=2.57.3)

Commands are suggestions: review each one before running it.

Loading voting…