@arikusi/deepseek-mcp-server: Missing Authentication on Self-Hosted HTTP MCP Endpoint
CVE-2026-55605GHSA-72f3-6w86-7rv3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@arikusi/deepseek-mcp-server 1.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @arikusi/deepseek-mcp-server
- Affected
- >= 1.4.2, < 1.8.0
- Fixed in
- 1.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-72f3-6w86-7rv3 lists affected ranges: npm @arikusi/deepseek-mcp-server >=1.4.2 <1.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-55605: 0.52% estimated exploitation activity in the next 30 days; percentile 44.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The self-hosted HTTP transport of @arikusi/deepseek-mcp-server exposes POST /mcp without any authentication: createMcpExpressApp is called without an authProvider and no middleware guards the route, so any network-reachable client can issue an unauthenticated initialize request and obtain a valid MCP session identifier. In reproduced testing against commit 5e1302171e99, an unauthenticated client was able to initialize a session, enumerate tools, and invoke the local deepseeksessions tool with no credentials. The same unauthenticated session also exposes deepseekchat, whose handler uses the server-side DEEPSEEKAPIKEY when self-hosted deployments configure one. This issue applies to self-hosted HTTP mode, not the separately documented hosted BYOK endpoint in README.md, which expects an Authorization: Bearer ... header. Upstream self-hosted container assets enable HTTP mode by default (Dockerfile) and publish port 3000 (docker-compose.yml). Affected Code src/transport-http.ts:17…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-72f3-6w86-7rv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55605 Advisory: @arikusi/deepseek-mcp-server: Missing Authentication on Self-Hosted HTTP MCP Endpoint IDs: CVE-2026-55605, GHSA-72f3-6w86-7rv3 Record: https://patchnext.com/advisories/cve-2026-55605 (revision 1, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @arikusi/deepseek-mcp-server 1.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @arikusi/deepseek-mcp-server: affected >= 1.4.2, < 1.8.0; fixed in 1.8.0 ## Suggested inspection (read-only) - `npm ls @arikusi/deepseek-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @arikusi/deepseek-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-72f3-6w86-7rv3 (GitHub-reviewed advisory GHSA-72f3-6w86-7rv3 lists affected ranges: npm @arikusi/deepseek-mcp-server >=1.4.2 <1.8.0) Commands are suggestions: review each one before running it.
Loading voting…