@arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key
CVE-2026-55604GHSA-fh3r-g96v-f578
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@arikusi/deepseek-mcp-server 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @arikusi/deepseek-mcp-server
- Affected
- >= 1.4.2, < 1.7.0
- Fixed in
- 1.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fh3r-g96v-f578 lists affected ranges: npm @arikusi/deepseek-mcp-server >=1.4.2 <1.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2026-55604: 0.37% estimated exploitation activity in the next 30 days; percentile 31.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-Session Data Exposure via Caller-Controlled sessionid Project / Repository: arikusi/deepseek-mcp-server Affected version / commit tested: 1.6.0 / 04f28be2c6e99d3d4e443a6ae37cc35f0a71554a Vulnerability type: Authorization bypass / cross-session data exposure Authentication required: No Summary The process-global SessionStore accepts caller-supplied sessionid values without binding them to any authenticated principal or transport session. An attacker can enumerate active session IDs via deepseeksessions, then reuse a victim-controlled sessionid in deepseekchat to retrieve and continue the victim's conversation context. Affected Code - src/session.ts:42 - caller-controlled session IDs are looked up directly from the global in-memory map. - src/session.ts:67 - a new session is stored under the caller-controlled ID without ownership binding. - src/session.ts:109 - getMessages() retrieves messages for any supplied session ID. - src/tools/deepseek-chat.ts:195 - deepseekchat creates or…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fh3r-g96v-f578
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55604 Advisory: @arikusi/deepseek-mcp-server has an Authorization Bypass Through User-Controlled Key IDs: CVE-2026-55604, GHSA-fh3r-g96v-f578 Record: https://patchnext.com/advisories/cve-2026-55604 (revision 1, source checked 26 Oct 2026, 13:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @arikusi/deepseek-mcp-server 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @arikusi/deepseek-mcp-server: affected >= 1.4.2, < 1.7.0; fixed in 1.7.0 ## Suggested inspection (read-only) - `npm ls @arikusi/deepseek-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @arikusi/deepseek-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fh3r-g96v-f578 (GitHub-reviewed advisory GHSA-fh3r-g96v-f578 lists affected ranges: npm @arikusi/deepseek-mcp-server >=1.4.2 <1.7.0) Commands are suggestions: review each one before running it.
Loading voting…