Skip to content

← Actionable
High, CVSS 7.5amended

http-proxy-middleware: multipart/form-data field injection via unescaped CRLF in fixRequestBody

CVE-2026-55603GHSA-gcq2-9pq2-cxqm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (http-proxy-middleware 4.1.1, 3.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N
EPSS
  • CVE-2026-55603: 0.29% estimated exploitation activity in the next 30 days; percentile 21.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary fixRequestBody() is the library's documented helper for re-emitting a request body that was already consumed by a body parser. When the outgoing Content-Type is multipart/form-data, it rebuilds the body with handlerFormDataBodyData(), which interpolates each req.body key and value directly into the multipart wire format without neutralizing CR/LF: A \r\n inside a value (or key) lets an attacker close the current part and inject an entirely new form part. Because the proxy's own body parser saw a single opaque value, any gateway-side policy or validation performed on req.body is evaluated against a different set of fields than the upstream backend ultimately parses a request/parameter desynchronization across the trust boundary. By contrast, the sibling output branches are safe: application/json uses JSON.stringify (escapes control chars) and application/x-www-form-urlencoded uses querystring.stringify (percent-encodes). Only the multipart branch lacks escaping. Preconditions…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-gcq2-9pq2-cxqm

  2. Revision 1 · created ·

    Published from osv record GHSA-gcq2-9pq2-cxqm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-55603

Advisory: http-proxy-middleware: multipart/form-data field injection via unescaped CRLF in `fixRequestBody`
IDs: CVE-2026-55603, GHSA-gcq2-9pq2-cxqm
Record: https://patchnext.com/advisories/cve-2026-55603 (revision 2, source checked 26 Oct 2026, 12:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: http-proxy-middleware 4.1.1, 3.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm http-proxy-middleware: affected >= 3.0.4, < 3.0.7; >= 4.0.0, < 4.1.1; fixed in 4.1.1, 3.0.7

## Suggested inspection (read-only)
- `npm ls http-proxy-middleware --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on http-proxy-middleware.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gcq2-9pq2-cxqm (OSV record GHSA-gcq2-9pq2-cxqm lists affected ranges: npm http-proxy-middleware >=3.0.4 =4.0.0 <4.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-gcq2-9pq2-cxqm (GitHub-reviewed advisory GHSA-gcq2-9pq2-cxqm lists affected ranges: npm http-proxy-middleware >=3.0.4 =4.0.0 <4.1.1)

Commands are suggestions: review each one before running it.

Loading voting…