http-proxy-middleware router host+path substring matching allows Host-header-driven backend routing bypass
CVE-2026-55602GHSA-64mm-vxmg-q3vj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (http-proxy-middleware 4.1.0, 3.0.6, 2.0.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.0.0, < 4.1.0>= 3.0.0, < 3.0.6>= 0.16.0, < 2.0.10
- Fixed in
- 2.0.10, 3.0.6, 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-64mm-vxmg-q3vj lists affected ranges: npm http-proxy-middleware >=3.0.0 =4.0.0 =0.16.0 <2.0.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-64mm-vxmg-q3vj lists affected ranges: npm http-proxy-middleware >=4.0.0 =3.0.0 =0.16.0 <2.0.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-55602: 0.38% estimated exploitation activity in the next 30 days; percentile 31.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary http-proxy-middleware documents router proxy-table entries as host, path, or host+path selectors, but the host+path implementation uses unanchored substring matching on attacker-controlled request metadata. As a result, a crafted Host header that is only a superstring match for a configured host+path key can still route a request to an unintended backend. Details Tested code state: - validated on tag v4.0.0-beta.5 - corresponding commit: 339f09ede860197807d4fd99ed9020fa5d0bd358 Relevant code locations: - src/router.ts - src/http-proxy-middleware.ts Affected public API: - createProxyMiddleware({ router: { 'host/path': 'http://target' } }) Code explanation: When a proxy-table router key contains /, getTargetFromProxyTable() concatenates attacker-controlled req.headers.host and req.url into a single hostAndPath string, then accepts the route if: That is a substring test, not an exact host match plus intended path match. In the validated PoC, the configured router key is: but the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-64mm-vxmg-q3vj
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-64mm-vxmg-q3vj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55602 Advisory: http-proxy-middleware `router` host+path substring matching allows Host-header-driven backend routing bypass IDs: CVE-2026-55602, GHSA-64mm-vxmg-q3vj Record: https://patchnext.com/advisories/cve-2026-55602 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: http-proxy-middleware 4.1.0, 3.0.6, 2.0.10. A vendor fix does not mean a deployment is fixed. ## Affected components - npm http-proxy-middleware: affected >= 4.0.0, < 4.1.0; >= 3.0.0, < 3.0.6; >= 0.16.0, < 2.0.10; fixed in 2.0.10, 3.0.6, 4.1.0 ## Suggested inspection (read-only) - `npm ls http-proxy-middleware --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on http-proxy-middleware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-64mm-vxmg-q3vj (OSV record GHSA-64mm-vxmg-q3vj lists affected ranges: npm http-proxy-middleware >=3.0.0 =4.0.0 =0.16.0 <2.0.10 (fixed)) - Verified: https://github.com/advisories/GHSA-64mm-vxmg-q3vj (GitHub-reviewed advisory GHSA-64mm-vxmg-q3vj lists affected ranges: npm http-proxy-middleware >=4.0.0 =3.0.0 =0.16.0 <2.0.10) Commands are suggestions: review each one before running it.
Loading voting…