phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access
CVE-2026-55599GHSA-m557-wrgg-6rp4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpseclib/phpseclib 3.0.54, 2.0.55, 1.0.30), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpseclib/phpseclib
- Affected
- >= 0.1.1, <= 1.0.29>= 2.0.0, <= 2.0.54>= 3.0.0, <= 3.0.53
- Fixed in
- 2.0.55, 3.0.54, 1.0.30
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m557-wrgg-6rp4 lists affected ranges: Packagist phpseclib/phpseclib >=0.1.1 =2.0.0 =3.0.0 <=3.0.53
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-55599: 0.21% estimated exploitation activity in the next 30 days; percentile 11.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When an application validates an untrusted X.509 certificate with phpseclib, X509::validateSignature() reads a URL out of that certificate's Authority Information Access (AIA) extension and connects to it. Attacker who supplies certificate fully controls host, port, and path of that connection. URL fetching is enabled by default, and no destination is blocked. An unauthenticated attacker can therefore make a validating server open connections to internal hosts and ports it should never reach, for example loopback 127.0.0.1, cloud metadata address 169.254.169.254, and internal-only services. This is a server-side request forgery (SSRF) caused by an insecure default. It is reproducible on current released LTS 3.0.53 and on 4.0 development line. Details When no already-trusted certificate authority is the issuer of certificate under validation, validateSignatureCountable() continues to AIA fetching. Default for validateSignature() is caonly = true: testForIntermediate() takes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m557-wrgg-6rp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-55599 Advisory: phpseclib: X.509 certificate validation sends attacker-controlled outbound requests (server-side request forgery) via Authority Information Access IDs: CVE-2026-55599, GHSA-m557-wrgg-6rp4 Record: https://patchnext.com/advisories/cve-2026-55599 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpseclib/phpseclib 3.0.54, 2.0.55, 1.0.30. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpseclib/phpseclib: affected >= 0.1.1, <= 1.0.29; >= 2.0.0, <= 2.0.54; >= 3.0.0, <= 3.0.53; fixed in 2.0.55, 3.0.54, 1.0.30 ## Suggested inspection (read-only) - Packagist phpseclib/phpseclib: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpseclib/phpseclib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m557-wrgg-6rp4 (GitHub-reviewed advisory GHSA-m557-wrgg-6rp4 lists affected ranges: Packagist phpseclib/phpseclib >=0.1.1 =2.0.0 =3.0.0 <=3.0.53) Commands are suggestions: review each one before running it.
Loading voting…